summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-15 15:26:51 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-15 15:48:32 +0200
commit803a1db739bc2844b1328af699efbb04067ea6d5 (patch)
treec7d50fcc3a14b426c0b3296a1541ac2e5fabd714 /dev-python/flake8-polyfill
parentapp-editors/emacs: Restore Motif support for emacs-28 and master (diff)
downloadgentoo-803a1db739bc2844b1328af699efbb04067ea6d5.tar.gz
gentoo-803a1db739bc2844b1328af699efbb04067ea6d5.tar.bz2
gentoo-803a1db739bc2844b1328af699efbb04067ea6d5.zip
dev-python/flake8-polyfill: enable py3.10, ebuild cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flake8-polyfill')
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
index da199eabc872..e9866fde8326 100644
--- a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
@@ -1,35 +1,31 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Polyfill package for Flake8 plugins"
HOMEPAGE="https://gitlab.com/pycqa/flake8-polyfill"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-EGIT_REPO_URI="https://gitlab.com/pycqa/flake8-polyfill.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pycodestyle[${PYTHON_USEDEP}]
- )"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
-python_prepare_all() {
+EPYTEST_IGNORE=(
# Get rid of the test that seems to test only the migration from
# pep8 to pycodestyle (bug 598918).
- rm "tests/test_stdin.py" || die
+ tests/test_stdin.py
+)
+
+src_prepare() {
sed -e 's|\[pytest\]|\[tool:pytest\]|' -i setup.cfg || die
- distutils-r1_python_prepare_all
+ distutils-r1_src_prepare
}