summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-26 05:37:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-26 05:37:12 +0100
commitffd860b2f58bfa0538bcc250c4de7df22648c01f (patch)
treedb82c520e591e36feffbcc25a026ce059aa1a20c /dev-python/fastjsonschema
parentdev-python/dkimpy: Bump to 1.1.0 (diff)
downloadgentoo-ffd860b2f58bfa0538bcc250c4de7df22648c01f.tar.gz
gentoo-ffd860b2f58bfa0538bcc250c4de7df22648c01f.tar.bz2
gentoo-ffd860b2f58bfa0538bcc250c4de7df22648c01f.zip
dev-python/fastjsonschema: Bump to 2.16.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.16.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 4511d43f6afb..1819519283b3 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST python-fastjsonschema-2.16.2.gh.tar.gz 391619 BLAKE2B ea8da31d16ec7c9a897de0b2a91832ce26798d2dc048e70e862ce7a4e75787cd25ee4b9e14fac9f85599e050338b6306a2549a0a8bab9abcbfbd12c246d10697 SHA512 17fce033e6d334e82813af7366006ade29433efe291a1567ae494c2273b9ab87b8fa4ccf1bae0b7062f9f70fe492449c87a5d07075d79037ac2c755ed9278a23
+DIST python-fastjsonschema-2.16.3.gh.tar.gz 392011 BLAKE2B 04990592a2bf6e1309bf725361ef7c2e253c4765c5b9d60805c5e6189f14885a3b0bae98945c2fe228adc335ca8c8c0a243b283b24fa447238d6415d439288e2 SHA512 2e26f31f9c6966e77f70b8ca584e672d554219b6bbb4811e3ac8dff1c693b2638ef08b8b9011e0db6f739be02e2f41a35d15bcfc42a9cb06ddb4521e51f37d8a
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.16.3.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.16.3.ebuild
new file mode 100644
index 000000000000..453a2cbc2332
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.16.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}