summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/execnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest2
-rw-r--r--dev-python/execnet/execnet-1.2.0-r2.ebuild48
-rw-r--r--dev-python/execnet/execnet-1.3.0.ebuild49
-rw-r--r--dev-python/execnet/files/1.2.0-tests.patch115
-rw-r--r--dev-python/execnet/metadata.xml14
5 files changed, 228 insertions, 0 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
new file mode 100644
index 000000000000..82658ac0e0f6
--- /dev/null
+++ b/dev-python/execnet/Manifest
@@ -0,0 +1,2 @@
+DIST execnet-1.2.0.tar.gz 163876 SHA256 951714caa0ae80237f4ffc1f08450e9e2e5f8f902beaf1ad294020875d6f8c2c SHA512 bf4eb1c07832628863f3d315510628343bc4504050311a277a86100a825df8ed5f6b65f58db28ea6733f3886b6007eae7fd33586721374f9ffb3687e9b95d5c4 WHIRLPOOL 898d9427d55e316f2cdfe06d8dadd0f40d8d2374802b419c9b7aac279eed36919f8dc0084c9c253b3b3d75e9dd50ec2748ef2227e803bf900d7d8b0d5395c45e
+DIST execnet-1.3.0.tar.gz 170489 SHA256 ecdfd5613cc78fe99aaf3e351bc870d1428202d78744ea48c893bf34a1fcbdbe SHA512 b047639ede7f5eeb600358bf983d1db617438a8ed9dcaa6e0ba470fe15703f2ce8d3f413a6b6dc575c0090744fde82ba3ba0e684bdeda86a6261941125c71a10 WHIRLPOOL 54d6cebfabcabfd5c3baebadd66fe8837c79cead4900ec1b9d55478d2eb2cbd77be9dfbb108b4049836b5cd316316bd4304b11377d372e5d5b8ef23f684e5838
diff --git a/dev-python/execnet/execnet-1.2.0-r2.ebuild b/dev-python/execnet/execnet-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..ffc44038b52d
--- /dev/null
+++ b/dev-python/execnet/execnet-1.2.0-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ http://pypi.python.org/pypi/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
+
+python_prepare_all() {
+ # Remove doctest that access an i'net site
+ rm doc/example/test_info.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bitbucket.org/hpk42/execnet/issue/10
+ unset PYTHONDONTWRITEBYTECODE
+ py.test testing || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/execnet/execnet-1.3.0.ebuild b/dev-python/execnet/execnet-1.3.0.ebuild
new file mode 100644
index 000000000000..79473245bf26
--- /dev/null
+++ b/dev-python/execnet/execnet-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ http://pypi.python.org/pypi/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+#PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
+
+python_prepare_all() {
+ # Remove doctest that access an i'net site
+ rm doc/example/test_info.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bitbucket.org/hpk42/execnet/issue/10
+ unset PYTHONDONTWRITEBYTECODE
+ py.test testing || die "Tests fail with ${EPYTHON}"
+
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/execnet/files/1.2.0-tests.patch b/dev-python/execnet/files/1.2.0-tests.patch
new file mode 100644
index 000000000000..13bed5d59605
--- /dev/null
+++ b/dev-python/execnet/files/1.2.0-tests.patch
@@ -0,0 +1,115 @@
+# HG changeset patch
+# User holger krekel <holger@merlinux.eu>
+# Date 1412585605 -7200
+# Node ID c9303c302995a4fb844553d4977c55abc72e2020
+# Parent 47ff3652b0aed191f7bafc741c211d1415f65224
+fix issue35: adapt some doctests, fix some channel tests for py3.
+Also modernize tox.ini a bit.
+--rebased
+diff -ur execnet-1.2.0.orig/doc/example/test_group.txt execnet-1.2.0/doc/example/test_group.txt
+--- doc/example/test_group.txt 2014-01-29 19:50:22.000000000 +0800
++++ doc/example/test_group.txt 2014-10-10 19:51:00.108828123 +0800
+@@ -14,7 +14,7 @@
+ >>> group
+ <Group ['gw0', 'gw1']>
+ >>> list(group)
+- [<PopenGateway id='gw0' receive-live, 0 active channels>, <PopenGateway id='gw1' receive-live, 0 active channels>]
++ [<Gateway id='gw0' receive-live, thread model, 0 active channels>, <Gateway id='gw1' receive-live, thread model, 0 active channels>]
+ >>> 'gw0' in group and 'gw1' in group
+ True
+ >>> group['gw0'] == group[0]
+@@ -37,7 +37,7 @@
+ >>> gw = group.makegateway("popen//id=sub1")
+ >>> assert gw.id == "sub1"
+ >>> group['sub1']
+- <PopenGateway id='sub1' receive-live, 0 active channels>
++ <Gateway id='sub1' receive-live, thread model, 0 active channels>
+
+ Getting (auto) IDs before instantiation
+ ------------------------------------------------------
+diff -ur execnet-1.2.0.orig/doc/example/test_proxy.txt execnet-1.2.0/doc/example/test_proxy.txt
+--- doc/example/test_proxy.txt 2014-01-29 19:50:22.000000000 +0800
++++ doc/example/test_proxy.txt 2014-10-10 19:16:50.380156509 +0800
+@@ -18,10 +18,10 @@
+ >>> group.defaultspec = 'popen//via=master'
+ >>> master = group.makegateway('popen//id=master')
+ >>> master
+- <Gateway id='master' receive-live, 0 active channels>
++ <Gateway id='master' receive-live, thread model, 0 active channels>
+ >>> slave = group.makegateway()
+ >>> slave
+- <Gateway id='gw0' receive-live, 0 active channels>
++ <Gateway id='gw0' receive-live, thread model, 0 active channels>
+ >>> group
+ <Group ['master', 'gw0']>
+
+diff -ur execnet-1.2.0.orig/testing/test_channel.py execnet-1.2.0/testing/test_channel.py
+--- testing/test_channel.py 2014-01-29 19:50:22.000000000 +0800
++++ testing/test_channel.py 2014-10-10 19:21:00.943955387 +0800
+@@ -68,25 +68,19 @@
+
+ def test_channel_error_reporting(self, gw):
+ channel = gw.remote_exec('def foo():\n return foobar()\nfoo()\n')
+- try:
+- channel.receive()
+- except channel.RemoteError:
+- e = sys.exc_info()[1]
+- assert str(e).startswith('Traceback (most recent call last):')
+- assert str(e).find('NameError: global name \'foobar\' '
+- 'is not defined') > -1
+- else:
+- pytest.fail('No exception raised')
++ excinfo = pytest.raises(channel.RemoteError, channel.receive)
++ msg = str(excinfo.value)
++ assert msg.startswith('Traceback (most recent call last):')
++ assert "NameError" in msg
++ assert "foobar" in msg
+
+ def test_channel_syntax_error(self, gw):
+ # missing colon
+ channel = gw.remote_exec('def foo()\n return 1\nfoo()\n')
+- try:
+- channel.receive()
+- except channel.RemoteError:
+- e = sys.exc_info()[1]
+- assert str(e).startswith('Traceback (most recent call last):')
+- assert str(e).find('SyntaxError') > -1
++ excinfo = pytest.raises(channel.RemoteError, channel.receive)
++ msg = str(excinfo.value)
++ assert msg.startswith('Traceback (most recent call last):')
++ assert "SyntaxError" in msg
+
+ def test_channel_iter(self, gw):
+ channel = gw.remote_exec("""
+diff -ur execnet-1.2.0.orig/tox.ini execnet-1.2.0/tox.ini
+--- tox.ini 2014-01-29 19:50:22.000000000 +0800
++++ tox.ini 2014-10-10 20:14:22.806301771 +0800
+@@ -1,16 +1,11 @@
+ [tox]
+-envlist=py26,py27,py32,py33,pypy,flakes
+-distshare={homedir}/.tox/distshare
+-
+-[tox:hudson]
+-distshare={toxworkdir}/distshare
+-sdistsrc={distshare}/execnet-*
++envlist=py26,py27,py33,py34,pypy,flakes
+
+ [testenv]
+ changedir=testing
+ deps=pytest
+ pytest-timeout
+-commands=py.test -rsfxX --junitxml={envlogdir}/junit-{envname}.xml []
++commands=py.test -rsfxX {posargs}
+
+ [testenv:flakes]
+ changedir=
+@@ -26,8 +21,7 @@
+ deps=sphinx
+ pytest
+ commands=
+- py.test \
+- -rsfxX -v --junitxml={envlogdir}/junit-{envname}.xml check_sphinx.py
++ py.test -rsfxX -v check_sphinx.py
+
+ [pytest]
+ timeout = 20
diff --git a/dev-python/execnet/metadata.xml b/dev-python/execnet/metadata.xml
new file mode 100644
index 000000000000..e0ad54d79cae
--- /dev/null
+++ b/dev-python/execnet/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Interact with Python interpreters
+ across version, platform and network barriers.</longdescription>
+ <upstream>
+ <remote-id type="pypi">execnet</remote-id>
+ </upstream>
+</pkgmetadata>