summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-12 16:35:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-12 16:41:59 +0100
commit582179febd74afd4071d57f1b007e5399d36103b (patch)
treeb6265b847da69b22243bb184f6ca8b78d8790747 /dev-python/entrypoints/entrypoints-0.2.3.ebuild
parentdev-python/pyproj: Drop 1.9.5.1-r1 (diff)
downloadgentoo-582179febd74afd4071d57f1b007e5399d36103b.tar.gz
gentoo-582179febd74afd4071d57f1b007e5399d36103b.tar.bz2
gentoo-582179febd74afd4071d57f1b007e5399d36103b.zip
dev-python/entrypoints: Drop 0.2.3 and 0.3 (r0)
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/entrypoints/entrypoints-0.2.3.ebuild')
-rw-r--r--dev-python/entrypoints/entrypoints-0.2.3.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/entrypoints/entrypoints-0.2.3.ebuild b/dev-python/entrypoints/entrypoints-0.2.3.ebuild
deleted file mode 100644
index 61967611023d..000000000000
--- a/dev-python/entrypoints/entrypoints-0.2.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Discover and load entry points from installed packages"
-HOMEPAGE="https://github.com/takluyver/entrypoints"
-SRC_URI="https://github.com//takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}/${P}"-setup.py.patch
- "${FILESDIR}/${PN}"-0.2.1-init.py.patch
-)
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-
- mv "${WORKDIR}/${P}"/entrypoints.py "${WORKDIR}/${P}/${PN}/" || die
-}
-
-python_compile_all() {
- if use doc; then
- emake -C doc html
- HTML_DOCS=( doc/_build/html/. )
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
- py.test || die
-}