summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/encore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/encore')
-rw-r--r--dev-python/encore/Manifest3
-rw-r--r--dev-python/encore/encore-0.3.ebuild52
-rw-r--r--dev-python/encore/encore-0.4.0.ebuild50
-rw-r--r--dev-python/encore/encore-0.5.1.ebuild37
-rw-r--r--dev-python/encore/files/encore-0.5.1-pypy-tests.patch36
-rw-r--r--dev-python/encore/metadata.xml15
6 files changed, 193 insertions, 0 deletions
diff --git a/dev-python/encore/Manifest b/dev-python/encore/Manifest
new file mode 100644
index 000000000000..fb78dc54656e
--- /dev/null
+++ b/dev-python/encore/Manifest
@@ -0,0 +1,3 @@
+DIST encore-0.3.tar.gz 104057 SHA256 994a564140327a2caf9147407d42c249e1b10ccce76b506bbe3016fd76c14261 SHA512 d5ba216cc7cb3181b20d7cf4362def8a52f7d940380791c863b7e6b9f8c35f8c6eee1d2d3c9dd81fa593db92ccb22e6980e4e3582ce0be029a4511b11b9fe16b WHIRLPOOL 3a0e20b09dd4e47eb2ec015cc89c9123804a8c6ed9d8a31a4c60c913099741047c92663d34698835dc40d3d75055fababf789231e348139be35c1923e2403ea3
+DIST encore-0.4.0.tar.gz 51877 SHA256 22afbd51fc72dc0139c46bf02752e3213573fc54bdf764656dc6cea7d8846c2c SHA512 5a2bed4d47225e2fdd0f4c914e18c1fc4b8b4782c4be5d62b91c7ca7ae8b5a19598ebeeddc5d6a2531217b011021b3dd14b846f23f338447ce922de628529e4c WHIRLPOOL 1b124fad326a58ff65b85fcb54280ddc51dc14805f78ed5b6f9a4f10b21848ffac3a3e62d4ee0bdd53ee52aae4a7637cdf2d79b6b55905e807aada81bcc16169
+DIST encore-0.5.1.tar.gz 71248 SHA256 0e90fd798e3b274b7f41e2989f27a22b41ec331976753a804f27f5781012c3b2 SHA512 410d37bd326ac5b8433dd5896c3e167387e83380cc55efa7405b4c3f918108cee60e6d3c78c3ff41aa2b1f46939cb3c4e2e495b9f77a9c2483a77e1973bd2d17 WHIRLPOOL 3ed37349e3ad5db6979472b2808a11b7f43cc7e1074265dfb2ed2480b2890dca64af86e66bad9578184915f4e24577ab1715defeaba8e6610e33292fdab6fd16
diff --git a/dev-python/encore/encore-0.3.ebuild b/dev-python/encore/encore-0.3.ebuild
new file mode 100644
index 000000000000..acc2303ff36f
--- /dev/null
+++ b/dev-python/encore/encore-0.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: collection of core-level utility modules"
+HOMEPAGE="https://github.com/enthought/encore"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( dataflow.txt )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ if [[ ${EPYTHON} == python2.6 ]]; then
+ ewarn "Tests disabled for ${EPYTHON}"
+ return 0
+ fi
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/encore/encore-0.4.0.ebuild b/dev-python/encore/encore-0.4.0.ebuild
new file mode 100644
index 000000000000..906ff33c11ac
--- /dev/null
+++ b/dev-python/encore/encore-0.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: collection of core-level utility modules"
+HOMEPAGE="https://github.com/enthought/encore"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ if [[ ${EPYTHON} == python2.6 ]]; then
+ ewarn "Tests disabled for ${EPYTHON}"
+ return 0
+ fi
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/encore/encore-0.5.1.ebuild b/dev-python/encore/encore-0.5.1.ebuild
new file mode 100644
index 000000000000..bc0fe5be2920
--- /dev/null
+++ b/dev-python/encore/encore-0.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: collection of core-level utility modules"
+HOMEPAGE="https://github.com/enthought/encore"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${P}-pypy-tests.patch )
+
+python_test() {
+ "${PYTHON}" -m unittest discover ./${PN}/events || die
+ # PYTHONPATH goes astray & '-m unittest discover' loses its way. nose works
+ # https://github.com/enthought/encore/issues/84
+ # tests for storage simply aren't written to cater to pypy
+ if [[ "${EPYTHON}" == python2.7 ]]; then
+ nosetests ./${PN}/storage || die
+ fi
+}
diff --git a/dev-python/encore/files/encore-0.5.1-pypy-tests.patch b/dev-python/encore/files/encore-0.5.1-pypy-tests.patch
new file mode 100644
index 000000000000..c7673efa7c4c
--- /dev/null
+++ b/dev-python/encore/files/encore-0.5.1-pypy-tests.patch
@@ -0,0 +1,36 @@
+diff -ur encore-0.5.1.orig/encore/events/tests/test_event_manager.py encore-0.5.1/encore/events/tests/test_event_manager.py
+--- encore/events/tests/test_event_manager.py 2014-01-06 22:40:24.000000000 +0800
++++ encore/events/tests/test_event_manager.py 2014-05-05 17:56:16.606026933 +0800
+@@ -10,7 +10,7 @@
+ import mock
+ import weakref
+ import threading
+-
++import sys
+ # Local imports.
+ from encore.events.event_manager import EventManager, BaseEvent
+ from encore.events.api import (get_event_manager, set_event_manager,
+@@ -429,6 +429,7 @@
+ self.evt_mgr.emit(BaseEvent())
+ self.assertEqual(data, [1])
+
++ @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "test written for py2 garbage collection methods")
+ def test_method_weakref(self):
+ """ Test if methods do not prevent garbage collection of objects.
+ """
+@@ -464,6 +465,7 @@
+ self.evt_mgr.emit(obj)
+ self.assertEqual(data, [1, 2])
+
++ @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "test written for py2 garbage collection methods")
+ def test_method_collect(self):
+ """ Test if object garbage collection disconnects listener method.
+ """
+@@ -481,6 +483,7 @@
+ self.assertEqual(data, [])
+ self.assertEqual(len(list(self.evt_mgr.get_listeners(BaseEvent))), 0)
+
++ @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "test written for py2 garbage collection methods")
+ def test_method_disconnect(self):
+ """ Test if method disconnect works.
+ """
diff --git a/dev-python/encore/metadata.xml b/dev-python/encore/metadata.xml
new file mode 100644
index 000000000000..c1fb9cafc0f3
--- /dev/null
+++ b/dev-python/encore/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ This package consists of a collection of core utility packages
+ useful for building Python applications. This package is intended to
+ be at the bottom of the software stack and have zero required
+ external dependencies aside from the Python Standard Library.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">encore</remote-id>
+ <remote-id type="github">enthought/encore</remote-id>
+ </upstream>
+</pkgmetadata>