summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/enable
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/Manifest1
-rw-r--r--dev-python/enable/enable-4.4.1.ebuild64
-rw-r--r--dev-python/enable/files/enable-3.3.0-nofreetype.patch127
-rw-r--r--dev-python/enable/files/enable-4-rogue-tests.patch47
-rw-r--r--dev-python/enable/metadata.xml15
5 files changed, 254 insertions, 0 deletions
diff --git a/dev-python/enable/Manifest b/dev-python/enable/Manifest
new file mode 100644
index 000000000000..8be035dcb02f
--- /dev/null
+++ b/dev-python/enable/Manifest
@@ -0,0 +1 @@
+DIST enable-4.4.1.tar.gz 2507048 SHA256 6bdba2754410b89d6c0531482a20b930c2a3965d843f374eda7e1e1902a03bdb SHA512 72c879f19e26a4311b900cb4665969b9f806ce47b23c214a25e3ec308cc5300b6d71084a793215b05302fbeba09e13a4561e661c3bddb700d529bd31cfeb4dff WHIRLPOOL be172d97a979270b3a355436a323f72e00eb1fe1544cfd73091f6d56eded44b463198c48bbb8dbabc06e9a417cf24fdd898eecae316376cd1b9845cd4af03d02
diff --git a/dev-python/enable/enable-4.4.1.ebuild b/dev-python/enable/enable-4.4.1.ebuild
new file mode 100644
index 000000000000..7987e1a87db2
--- /dev/null
+++ b/dev-python/enable/enable-4.4.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx flag-o-matic
+
+DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
+HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
+SRC_URI="https://github.com/enthought/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4[${PYTHON_USEDEP}]
+ >=media-libs/freetype-2
+ virtual/opengl
+ virtual/glu
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/swig:0
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+
+ sed -e 's:html_favicon = "et.ico":html_favicon = "_static/et.ico":' \
+ -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ # https://github.com/enthought/enable/issues/158
+ PYTHONPATH=.:kiva \
+ VIRTUALX_COMMAND="nosetests" virtualmake
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/enable/files/enable-3.3.0-nofreetype.patch b/dev-python/enable/files/enable-3.3.0-nofreetype.patch
new file mode 100644
index 000000000000..56000986dff5
--- /dev/null
+++ b/dev-python/enable/files/enable-3.3.0-nofreetype.patch
@@ -0,0 +1,127 @@
+--- Enable-3.3.0.orig/enthought/kiva/agg/setup.py 2010-02-25 13:15:07.000000000 -0500
++++ Enable-3.3.0/enthought/kiva/agg/setup.py 2010-03-21 14:55:37.000000000 -0500
+@@ -4,59 +4,6 @@
+ import re
+ import platform
+
+-freetype2_sources =['autofit/autofit.c',
+- 'base/ftbase.c','base/ftsystem.c','base/ftinit.c',
+- 'base/ftglyph.c','base/ftmm.c','base/ftbdf.c',
+- 'base/ftbbox.c','base/ftdebug.c','base/ftxf86.c',
+- 'base/fttype1.c',
+- 'bdf/bdf.c',
+- 'cff/cff.c',
+- 'cid/type1cid.c',
+- 'lzw/ftlzw.c',
+- 'pcf/pcf.c','pfr/pfr.c',
+- 'psaux/psaux.c',
+- 'pshinter/pshinter.c',
+- 'psnames/psnames.c',
+- 'raster/raster.c',
+- 'sfnt/sfnt.c',
+- 'smooth/smooth.c',
+- 'truetype/truetype.c',
+- 'type1/type1.c',
+- 'type42/type42.c',
+- 'winfonts/winfnt.c',
+- 'gzip/ftgzip.c',
+- 'base/ftmac.c',
+- ]
+-
+-freetype2_dirs = [
+- 'autofit',
+- 'base',
+- 'bdf',
+- 'cache',
+- 'cff',
+- 'cid',
+- 'gxvalid',
+- 'gzip',
+- 'lzw',
+- 'otvalid',
+- 'pcf',
+- 'pfr',
+- 'psaux',
+- 'pshinter',
+- 'psnames',
+- 'raster',
+- 'sfnt',
+- 'smooth',
+- 'tools',
+- 'truetype',
+- 'type1',
+- 'type42',
+- 'winfonts',
+- 'gzip'
+- ]
+-
+-
+-
+ def configuration(parent_package='',top_path=None):
+ from numpy.distutils.misc_util import Configuration
+ from numpy.distutils.system_info import dict_append, get_info
+@@ -85,45 +32,11 @@
+ plat = 'x11' # use with gtk2, it's slow but reliable
+ #plat = 'gdkpixbuf2'
+
+-
+- #-------------------------------------------------------------------------
+- # Add the freetype library (agg 2.4 links against this)
+- #-------------------------------------------------------------------------
+-
+- prefix = config.paths('freetype2/src')[0]
+- freetype_lib = 'freetype2_src'
+-
+- def get_ft2_sources((lib_name, build_info), build_dir):
+- sources = [prefix + "/" + s for s in freetype2_sources]
+- if sys.platform=='darwin':
+- return sources[:]
+- return sources[:-1]
+-
+- ft2_incl_dirs = ['freetype2/src/' + s for s in freetype2_dirs] \
+- + ['freetype2/include', 'freetype2/src']
+- ft2_incl_dirs = config.paths(*ft2_incl_dirs)
+- if sys.platform == 'darwin':
+- ft2_incl_dirs.append("/Developer/Headers/FlatCarbon")
+-
+- config.add_library(freetype_lib,
+- sources = [get_ft2_sources],
+- include_dirs = ft2_incl_dirs,
+-
+- # This macro was introduced in Freetype 2.2; if it is
+- # not defined, then the ftheader.h file (one of the
+- # primary headers) won't pull in any additional internal
+- # Freetype headers, and the library will mysteriously
+- # fail to build.
+- macros = [("FT2_BUILD_LIBRARY", None)],
+-
+- depends = ['freetype2'],
+- )
+-
+ #-------------------------------------------------------------------------
+ # Add the Agg sources
+ #-------------------------------------------------------------------------
+
+- agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ft2_incl_dirs
++ agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ["/usr/include/freetype2/"]
+ agg_sources = [agg_dir+'/src/*.cpp',
+ agg_dir+'/font_freetype/*.cpp']
+ config.add_library(agg_lib,
+@@ -137,7 +50,7 @@
+ if sys.platform == 'darwin':
+ define_macros = [('__DARWIN__', None)]
+ macros = [('__DARWIN__', None)]
+- extra_link_args = ['-framework', 'Carbon']
++ extra_link_args = ['-framework', 'Carbon', '-Wl,-search_paths_first']
+ else:
+ define_macros = []
+ macros = []
+@@ -191,7 +104,7 @@
+
+ build_info = {}
+ kiva_lib = 'kiva_src'
+- build_libraries = [kiva_lib, agg_lib, freetype_lib]
++ build_libraries = [kiva_lib, agg_lib, "freetype"]
+ if sys.platform == "win32":
+ build_libraries += ["opengl32", "glu32"]
+ elif sys.platform == "darwin":
diff --git a/dev-python/enable/files/enable-4-rogue-tests.patch b/dev-python/enable/files/enable-4-rogue-tests.patch
new file mode 100644
index 000000000000..f08f7b00ce36
--- /dev/null
+++ b/dev-python/enable/files/enable-4-rogue-tests.patch
@@ -0,0 +1,47 @@
+diff -ur enable-4.3.0.orig/enable/savage/svg/tests/test_document.py enable-4.3.0/enable/savage/svg/tests/test_document.py
+--- enable/savage/svg/tests/test_document.py 2013-03-28 21:58:28.000000000 +0800
++++ enable/savage/svg/tests/test_document.py 2013-05-14 21:23:18.641569707 +0800
+@@ -63,6 +63,7 @@
+ 0
+ )
+
++ @unittest.skip("This tests accesses the internet")
+ def testURLFallback(self):
+ self.document.state["fill"] = "url(http://google.com) red"
+ self.assertEqual(
+diff -ur enable-4.3.0.orig/enable/tests/kiva_graphics_context_test_case.py enable-4.3.0/enable/tests/kiva_graphics_context_test_case.py
+--- enable/tests/kiva_graphics_context_test_case.py 2013-03-28 21:58:28.000000000 +0800
++++ enable/tests/kiva_graphics_context_test_case.py 2013-05-14 21:24:53.897573114 +0800
+@@ -1,4 +1,3 @@
+-
+ import numpy as np
+ import unittest
+
+@@ -8,6 +7,7 @@
+ class TestGCErrors(unittest.TestCase):
+ """Test some cases where a ValueError should be raised."""
+
++ @unittest.expectedFailure
+ def test_bad_image_size(self):
+ arr = np.array([[1, 2], [3, 4]], dtype=np.uint8)
+ gc = GraphicsContext((50, 50))
+diff -ur enable-4.3.0.orig/kiva/quartz/__init__.py enable-4.3.0/kiva/quartz/__init__.py
+--- kiva/quartz/__init__.py 2013-03-28 21:58:28.000000000 +0800
++++ kiva/quartz/__init__.py 2013-05-14 21:32:10.473588730 +0800
+@@ -2,16 +2,3 @@
+ # :Copyright: 2004, Enthought, Inc.
+ # :License: BSD Style
+
+-from mac_context import get_mac_context
+-
+-
+-def get_macport(dc):
+- """
+- Returns the Port or the CGContext of a wxDC (or child class) instance.
+- """
+- if 'GetCGContext' in dir(dc):
+- ptr = dc.GetCGContext()
+- return int(ptr)
+- else:
+- from macport import get_macport as _get_macport
+- return _get_macport(str(dc.this))
diff --git a/dev-python/enable/metadata.xml b/dev-python/enable/metadata.xml
new file mode 100644
index 000000000000..85360f54f069
--- /dev/null
+++ b/dev-python/enable/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ The Enable project from the Enthought Tool Suite provides two
+ related multi-platform packages for drawing GUI objects:
+ * Enable: An object drawing library that supports containment and
+ event notification.
+ * Kiva: A multi-platform DisplayPDF vector drawing engine.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">enthought/enable</remote-id>
+ </upstream>
+</pkgmetadata>