summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-23 08:53:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-23 08:53:45 +0200
commitdcedde8441339662edf5727b7d3d470dd70d76e8 (patch)
tree13c68c67879bcab5a4d71b61d949e1bae25cf531 /dev-python/easyprocess/easyprocess-1.1-r1.ebuild
parentxfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.8 (diff)
downloadgentoo-dcedde8441339662edf5727b7d3d470dd70d76e8.tar.gz
gentoo-dcedde8441339662edf5727b7d3d470dd70d76e8.tar.bz2
gentoo-dcedde8441339662edf5727b7d3d470dd70d76e8.zip
dev-python/easyprocess: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/easyprocess/easyprocess-1.1-r1.ebuild')
-rw-r--r--dev-python/easyprocess/easyprocess-1.1-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/easyprocess/easyprocess-1.1-r1.ebuild b/dev-python/easyprocess/easyprocess-1.1-r1.ebuild
index ef07caf72d06..2dbb1d8a20f1 100644
--- a/dev-python/easyprocess/easyprocess-1.1-r1.ebuild
+++ b/dev-python/easyprocess/easyprocess-1.1-r1.ebuild
@@ -3,13 +3,20 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1
DESCRIPTION="Easy to use Python subprocess interface"
-HOMEPAGE="https://github.com/ponty/EasyProcess"
-SRC_URI="https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/ponty/EasyProcess/
+ https://pypi.org/project/EasyProcess/
+"
+SRC_URI="
+ https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
S="${WORKDIR}/EasyProcess-${PV}"
LICENSE="BSD-2"
@@ -22,7 +29,8 @@ BDEPEND="
dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
x11-base/xorg-server[xvfb]
- )"
+ )
+"
distutils_enable_tests pytest