summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-11 08:15:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-11 08:21:22 +0300
commit7f85777cab3b51b8c3f9b2e42cea4e4c5dbbc8b2 (patch)
treec85514b55caf63c80641e8d23ec814d31e1b2149 /dev-python/dogpile-cache
parentdev-python/Faker: add 13.13.0 (diff)
downloadgentoo-7f85777cab3b51b8c3f9b2e42cea4e4c5dbbc8b2.tar.gz
gentoo-7f85777cab3b51b8c3f9b2e42cea4e4c5dbbc8b2.tar.bz2
gentoo-7f85777cab3b51b8c3f9b2e42cea4e4c5dbbc8b2.zip
dev-python/dogpile-cache: add 1.1.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/dogpile-cache')
-rw-r--r--dev-python/dogpile-cache/Manifest1
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-1.1.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
index 63a08521f487..7d91507c9379 100644
--- a/dev-python/dogpile-cache/Manifest
+++ b/dev-python/dogpile-cache/Manifest
@@ -1 +1,2 @@
DIST dogpile.cache-1.1.5.tar.gz 392536 BLAKE2B 062392cda9b06da889f924bc04743faa133b978a908ffdbc1e9cc9a2a9a69db22ee26b27c7cb2ec2dedee20786cf90c6d02d163731224956091b2d3baa25774b SHA512 b6d453121ef8e58da60478e2e1e2db57804dfa3b17cceeace930ba75d159629dfba4b5d63c50fbbc2eafeadbfcd6e1e4cbe22c8da1f54c90473f8ee677d764f8
+DIST dogpile.cache-1.1.6.tar.gz 393076 BLAKE2B 62c16ee7cc00608432d45fa7cb068300a4417a494e4580a2af5c3f7c5a0bf40a54e1b6f4924bbd7b40a0efc1cb9afb42f361811c257fa77eabcd64cc35fbcf51 SHA512 179246abf598675cdef988b463df4997c7eed8e7a110c22704052f905b65ad537b22ba28d7c96a28b2aa85b3e83ac42beb36843dc78ad503d41225ea1f9e7e77
diff --git a/dev-python/dogpile-cache/dogpile-cache-1.1.6.ebuild b/dev-python/dogpile-cache/dogpile-cache-1.1.6.ebuild
new file mode 100644
index 000000000000..cebd949d705e
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-1.1.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value"
+HOMEPAGE="https://github.com/sqlalchemy/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest