summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-08 07:50:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-08 07:50:54 +0200
commit5e37b87c64f5bee59cdd7a990cc25dec12968751 (patch)
tree13f1d8dd75dbe9f93ccaf22fe0bef91f2ec47571 /dev-python/django-timezone-field
parentdev-python/python-lsp-jsonrpc: Bump to 1.1.0 (diff)
downloadgentoo-5e37b87c64f5bee59cdd7a990cc25dec12968751.tar.gz
gentoo-5e37b87c64f5bee59cdd7a990cc25dec12968751.tar.bz2
gentoo-5e37b87c64f5bee59cdd7a990cc25dec12968751.zip
dev-python/django-timezone-field: Bump to 6.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest1
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-6.0.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index d3735679cf38..83d5b3dd2a50 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1,2 +1,3 @@
DIST django-timezone-field-5.1.gh.tar.gz 37449 BLAKE2B 9676bd686f7a1bfb2d7e5ee53db5ca3818a9bc20c4c759c09c6d602bcb1937098c40b9c07b3db1d7ca8af2f8882d6aaa333f325e422725e3ea7303fc60e9b59c SHA512 518e16b092af00edae9b2488fd4e9380a661864e9f2d2d3ed8ffc6d9188831d4a7b79ed81d553bc41089ac8cb6fab760339af668ce7c2c0218d991b77306c50f
+DIST django-timezone-field-6.0.1.gh.tar.gz 35800 BLAKE2B f3b46970bbe234f786988d8c71a016c382ea3d82b798eaf78e685f86a80b3ebd3ee495d0f0230afb84f594b443548d9bc1e8891ea37c08be478bab388edfd70b SHA512 e6d1631af6a4d93f2fae236cf12d8fda15dfd6d70ee01c496364c3e5e141fff2bb5982f607adf474617a86b9f0f611306a17d1d892556a087424110ee3de541d
DIST django-timezone-field-6.0.gh.tar.gz 35628 BLAKE2B 3df5b07f4dc2d16ba71b0eacac90dd173f559322b14dba5ac62f5e336ccaeae3538b4464ad708ebadef92d317b1bc7ef859cde3a8005c9e4c31a2af3cd1d6e69 SHA512 efa15bf819e9a9fd35b4c373883f12aedd262c5223561bd3158acc3ebb9e4d72821153b5a48d544eebfe65342f8d33ce07b0b37bd847b1ec8d83d345e022c17c
diff --git a/dev-python/django-timezone-field/django-timezone-field-6.0.1.ebuild b/dev-python/django-timezone-field/django-timezone-field-6.0.1.ebuild
new file mode 100644
index 000000000000..cc484c7ef9e9
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-6.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for timezone objects"
+HOMEPAGE="
+ https://github.com/mfogel/django-timezone-field/
+ https://pypi.org/project/django-timezone-field/
+"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/django-5[${PYTHON_USEDEP}]
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}