summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-03 06:19:22 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-03 06:46:57 +0100
commit71af90a8f0ce289819fb63987d2dddf06f4aea20 (patch)
tree279256f5b263abbb783cac91671840ab3f27bdf2 /dev-python/django-tables2
parentdev-python/django-tables2: Remove old (diff)
downloadgentoo-71af90a8f0ce289819fb63987d2dddf06f4aea20.tar.gz
gentoo-71af90a8f0ce289819fb63987d2dddf06f4aea20.tar.bz2
gentoo-71af90a8f0ce289819fb63987d2dddf06f4aea20.zip
dev-python/django-tables2: Bump to 2.7.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-tables2')
-rw-r--r--dev-python/django-tables2/Manifest1
-rw-r--r--dev-python/django-tables2/django-tables2-2.7.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
index 2487a846a3d3..2415090e620e 100644
--- a/dev-python/django-tables2/Manifest
+++ b/dev-python/django-tables2/Manifest
@@ -1 +1,2 @@
DIST django-tables2-2.7.4.gh.tar.gz 432112 BLAKE2B 9327506570115f8bfdce95a753327d3ce94d6b9b03c250ee141c368fb872c0778f6b194aae9518abcdf8c3e53ea522ee7690ab86460694a86624d1d2572b0f98 SHA512 19437869dabf5376eb243aa6529c3e70b4448248c021d3bf8e64865bcdac0d21c5fbc91e5fb0891ee449c04c735f84a68916e15ce3149f3a4d7c05b4866ba705
+DIST django-tables2-2.7.5.gh.tar.gz 432318 BLAKE2B fc762afeba6332f61a48fb4f404e261dd483661b880e7baefe39593f4f0ca34e11326214c8f6b4d4eaa53c425793e6d07c73f039f0366c4e60f9d4b0588d3cde SHA512 b85bba6f1674497036e1c0c1ae5f05c241d951670501f2ca78aa62f1f278b455b9bde04f9f877a9972f92451ea1b296b39052da0da43f624bc270c787441e48a
diff --git a/dev-python/django-tables2/django-tables2-2.7.5.ebuild b/dev-python/django-tables2/django-tables2-2.7.5.ebuild
new file mode 100644
index 000000000000..bb6a388d97b5
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-2.7.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-tables2/
+ https://github.com/jieter/django-tables2/
+"
+SRC_URI="
+ https://github.com/jieter/django-tables2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/django-filter[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/psycopg:*[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # these tests require tablib
+ rm tests/test_export.py tests/test_templatetags.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" manage.py test -v 2 tests || die
+}