summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-03 08:45:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-03 09:51:32 +0200
commit29712993327faac4737662dd7502d228da17a5a4 (patch)
treeb44216394e1925ba0923d6ed9494928eb61b0925 /dev-python/django-prometheus
parentdev-python/trove-classifiers: Bump to 2023.5.2 (diff)
downloadgentoo-29712993327faac4737662dd7502d228da17a5a4.tar.gz
gentoo-29712993327faac4737662dd7502d228da17a5a4.tar.bz2
gentoo-29712993327faac4737662dd7502d228da17a5a4.zip
dev-python/django-prometheus: Bump to 2.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-prometheus')
-rw-r--r--dev-python/django-prometheus/Manifest1
-rw-r--r--dev-python/django-prometheus/django-prometheus-2.3.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/Manifest b/dev-python/django-prometheus/Manifest
index 6e515861f6ef..8e4ca9e2304b 100644
--- a/dev-python/django-prometheus/Manifest
+++ b/dev-python/django-prometheus/Manifest
@@ -1 +1,2 @@
DIST django-prometheus-2.2.0.tar.gz 24995 BLAKE2B db79cbed99d4d5cb7d9ce22dfee69914a63373417b176b4311406f9a1fdcada16447d6ec8cb19ebd14789f520aa1d5755aace824e5462611f81a0cc688566f19 SHA512 a72c8345f220799ad0709e0e73912229267b5e01fc67ae7f647e53ccf7c7e170ad2456c81070a002dc411e840b1129d55719a7aa891b4dabe262837c8c7b3db5
+DIST django-prometheus-2.3.1.tar.gz 24718 BLAKE2B a20f140736107e1c959fed33ff9a736cbc3266189598924e5d285c44a9fd1f16b7e41ba85829a2526cd49116523e1da3d1f96c9a1d73f84db18557cee3254982 SHA512 523cfa7023e1e8921c687bd010a4c6384e1e4142fb702887d1d0bd60194b5111e92e53fec07df89eaea07cd7aa806edef79ab303a67d866d18eacde257db3c03
diff --git a/dev-python/django-prometheus/django-prometheus-2.3.1.ebuild b/dev-python/django-prometheus/django-prometheus-2.3.1.ebuild
new file mode 100644
index 000000000000..680ccac5129a
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-2.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library to export Django metrics for Prometheus"
+HOMEPAGE="
+ https://github.com/korfuri/django-prometheus/
+ https://pypi.org/project/django-prometheus/
+"
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}