summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-21 17:31:42 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:18:56 +0000
commitc555e4cf9f23a7c2c4d876c9fa9689c35025f975 (patch)
tree9f09dfcbc1db9780cac077614a6149784d6d190d /dev-python/django-prometheus/django-prometheus-2.1.0.ebuild
parentmedia-sound/marrie: Sync live ebuild (diff)
downloadgentoo-c555e4cf9f23a7c2c4d876c9fa9689c35025f975.tar.gz
gentoo-c555e4cf9f23a7c2c4d876c9fa9689c35025f975.tar.bz2
gentoo-c555e4cf9f23a7c2c4d876c9fa9689c35025f975.zip
dev-python/django-prometheus: Bump to 2.1.0
Closes: https://bugs.gentoo.org/767010 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/django-prometheus/django-prometheus-2.1.0.ebuild')
-rw-r--r--dev-python/django-prometheus/django-prometheus-2.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/django-prometheus-2.1.0.ebuild b/dev-python/django-prometheus/django-prometheus-2.1.0.ebuild
new file mode 100644
index 000000000000..108c87dc5cd3
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-2.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Library to export Django metrics for Prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}