summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-17 09:54:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-17 09:56:27 +0200
commit97eb3e6d787209f1faa0789ba07a7e455f71dbd9 (patch)
treef277340d3ca8fda1de9df4b3f8df9bc8749971ce /dev-python/django-allauth
parentpax-utils.eclass: allow EAPI=8 (diff)
downloadgentoo-97eb3e6d787209f1faa0789ba07a7e455f71dbd9.tar.gz
gentoo-97eb3e6d787209f1faa0789ba07a7e455f71dbd9.tar.bz2
gentoo-97eb3e6d787209f1faa0789ba07a7e455f71dbd9.zip
dev-python/django-allauth: Bump to 0.45.0, add tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-allauth')
-rw-r--r--dev-python/django-allauth/Manifest1
-rw-r--r--dev-python/django-allauth/django-allauth-0.45.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-allauth/Manifest b/dev-python/django-allauth/Manifest
index 37b6c4f6d332..84f042f810c8 100644
--- a/dev-python/django-allauth/Manifest
+++ b/dev-python/django-allauth/Manifest
@@ -1 +1,2 @@
DIST django-allauth-0.42.0.tar.gz 549566 BLAKE2B aa346bcc47b9419776a68c023ab560e5cba0fd97eeaf4cb2f43da4b2c53619c65a3ec9e1313ff3ffa0ed051718d41ccea2d362f56d6bd8dcf4c5a0569ccbb7c9 SHA512 2c31a70dfd3becf0f921b0566204b8b3221b0c85e82cb8a8ad37ab557fc6f302b9c24bfdd6885978157f4ccb9044d1eed9973d066ee59877aee727c60d2a5b46
+DIST django-allauth-0.45.0.tar.gz 581007 BLAKE2B a0f586818e4d17ece5ed009481b71c0213bf265f45d391664d411268d53124c1d5df226ca40d98722691ace5f5ed50026b0a9db3bd34070ff855059bf3e237d6 SHA512 16b166a5f97e62fef3c801af17b6b7569bd27e597cec394032a2644397afc30512f52f0ff77af8036e414086cd207dc9f5d310dbc744627b55938243ba18e50f
diff --git a/dev-python/django-allauth/django-allauth-0.45.0.ebuild b/dev-python/django-allauth/django-allauth-0.45.0.ebuild
new file mode 100644
index 000000000000..acee98cb30f9
--- /dev/null
+++ b/dev-python/django-allauth/django-allauth-0.45.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Django 3rd party (social) account authentication"
+HOMEPAGE="
+ https://www.intenct.nl/projects/django-allauth/
+ https://github.com/pennersr/django-allauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# cryptography via pyjwt[crypto]
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/python3-openid[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+DOCS=( README.rst AUTHORS ChangeLog.rst )
+
+src_test() {
+ # cern provider tests require Internet
+ rm allauth/socialaccount/providers/cern/tests.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=test_settings
+ local -x PYTHONPATH=.
+ django-admin test -v 2 || die "Tests failed with ${EPYTHON}"
+}