summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-25 00:17:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-25 01:02:47 +0100
commitfd5eec3bd1a6d6dbbd4a3268e613f152ca7939b0 (patch)
tree30ce923382086261321c17ed583a1b6dd0428f80 /dev-python/dill
parentdev-python/pylint: Bump to 2.13.0 (diff)
downloadgentoo-fd5eec3bd1a6d6dbbd4a3268e613f152ca7939b0.tar.gz
gentoo-fd5eec3bd1a6d6dbbd4a3268e613f152ca7939b0.tar.bz2
gentoo-fd5eec3bd1a6d6dbbd4a3268e613f152ca7939b0.zip
dev-python/dill: EAPI 8, PEP517, py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/dill-0.3.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/dill/dill-0.3.4-r1.ebuild b/dev-python/dill/dill-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..d52d40d0b368
--- /dev/null
+++ b/dev-python/dill/dill-0.3.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend ${?} || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}