summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-25 06:26:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-25 07:02:04 +0100
commit16d3b8b3769bab679c69f4338092b78517214540 (patch)
tree806cf2eb3dc2d66185d2d5ed60d6042870b9b565 /dev-python/dict2xml
parentdev-python/zipp: Bump to 3.15.0 (diff)
downloadgentoo-16d3b8b3769bab679c69f4338092b78517214540.tar.gz
gentoo-16d3b8b3769bab679c69f4338092b78517214540.tar.bz2
gentoo-16d3b8b3769bab679c69f4338092b78517214540.zip
dev-python/dict2xml: Bump to 1.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dict2xml')
-rw-r--r--dev-python/dict2xml/Manifest1
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.3.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/dict2xml/Manifest b/dev-python/dict2xml/Manifest
index 238f7a0fee27..1c4821bc8d2e 100644
--- a/dev-python/dict2xml/Manifest
+++ b/dev-python/dict2xml/Manifest
@@ -1 +1,2 @@
DIST dict2xml-1.7.2.tar.gz 12295 BLAKE2B 7bd1c771f3b1c38f96bb322f88d78fb4ab763b153a0531f1953ad97e4b8eb93464a4cfb2aeaffc1599967145a54f0decc5152f3084587f6d94f25cdcbd5837c1 SHA512 fea3a65c5decfee8a22135fc262764c9afbc6b9f41232557f2de1b18a5b30e65c6910ef9f7d4e4b22c2d6c27d5b18eb6a83679c656564061bb7e5e8c55945c76
+DIST dict2xml-1.7.3.tar.gz 14240 BLAKE2B b28343f2cfeb59a91011bb158ffe7db008f19be1576293e6b07c3b49e07f3871761c8a3a32c214bf0608602487e2e7110c7f2a2f31a7dbf44a441f44ca7f568b SHA512 631415e425688c612c15b72fc339db33977df32eb25f7f8f03a63e5115c8e06f4aa5b247ded3e16cddbb9b16597aeb0ef218f193c5f4c44ebdcd7e39c2052ed2
diff --git a/dev-python/dict2xml/dict2xml-1.7.3.ebuild b/dev-python/dict2xml/dict2xml-1.7.3.ebuild
new file mode 100644
index 000000000000..97a64fe6615e
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# dict2xml uses noseOfYeti for its test, which is not yet available.
+RESTRICT="test"
+
+distutils_enable_tests pytest