summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-24 20:02:03 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-24 20:41:12 +0200
commitda0f62bc1a88d9b4a94249013057b7ecae404d7d (patch)
treef1be5c6d41790b4a67e9ad3d5a7211d7be23a665 /dev-python/debugpy
parentmedia-libs/tg_owt: Fix building without YASM (diff)
downloadgentoo-da0f62bc1a88d9b4a94249013057b7ecae404d7d.tar.gz
gentoo-da0f62bc1a88d9b4a94249013057b7ecae404d7d.tar.bz2
gentoo-da0f62bc1a88d9b4a94249013057b7ecae404d7d.zip
dev-python/debugpy: import from ::guru, new dep of ipykernel
Closes: https://bugs.gentoo.org/800133 Closes: https://bugs.gentoo.org/796854 Closes: https://bugs.gentoo.org/796857 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest1
-rw-r--r--dev-python/debugpy/debugpy-1.4.1.ebuild39
-rw-r--r--dev-python/debugpy/metadata.xml15
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
new file mode 100644
index 000000000000..f429037ba87b
--- /dev/null
+++ b/dev-python/debugpy/Manifest
@@ -0,0 +1 @@
+DIST debugpy-1.4.1.tar.gz 6687670 BLAKE2B c7761f354700d366d49365b0294ba1f07f357283c7527fc961c702bf99d808835741a899909e37092026c81ff19f6d96ef09c06512c8315ccad158b6e8e47697 SHA512 aef7779cb3a1af76b5cd3d6e8c7e0b78ffe08d1ebe25cf617ca3eb00966d5b3920358809c018f5f1f9eb56b913211134acfdba7d4c0d0174e4d6cfdae058d5f5
diff --git a/dev-python/debugpy/debugpy-1.4.1.ebuild b/dev-python/debugpy/debugpy-1.4.1.ebuild
new file mode 100644
index 000000000000..f49de56ebc48
--- /dev/null
+++ b/dev-python/debugpy/debugpy-1.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
+HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
+SRC_URI="https://github.com/microsoft/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# There is not enough time in the universe for this test suite
+RESTRICT="test"
+
+# These files are included pre-built in the sources
+# TODO: Investigate what this is and if/how we can compile this properly
+QA_PREBUILT="
+ /usr/lib/python*/site-packages/${PN}/_vendored/pydevd/pydevd_attach_to_process/attach_linux_*.so
+"
+
+python_prepare_all() {
+ # Drop unnecessary and unrecognized option
+ # __main__.py: error: unrecognized arguments: -n8
+ # Do not timeout
+ sed -i \
+ -e 's/-n8//g' \
+ -e '/timeout/d' \
+ pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest
diff --git a/dev-python/debugpy/metadata.xml b/dev-python/debugpy/metadata.xml
new file mode 100644
index 000000000000..a8dc72385883
--- /dev/null
+++ b/dev-python/debugpy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">debugpy</remote-id>
+ <maintainer status="unknown">
+ <email>ptvshelp@microsoft.com</email>
+ <name>Microsoft Corporation</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>