summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-03 18:12:16 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-03 18:15:11 -0500
commit0d9f3349d90bf860146dcd5f179c370488b4baec (patch)
treeb5bdc7b6b4925c7393e06961aca5e065bce43236 /dev-python/cssutils
parentkde-plasma: Drop KDE Plasma 5.17.3 (diff)
downloadgentoo-0d9f3349d90bf860146dcd5f179c370488b4baec.tar.gz
gentoo-0d9f3349d90bf860146dcd5f179c370488b4baec.tar.bz2
gentoo-0d9f3349d90bf860146dcd5f179c370488b4baec.zip
dev-python/cssutils: fix tests
* Casing issue discovered for calls to Windows-1252 vs windows-1252 Suggested-by: Patrick McLean <chutzpah@gentoo.org> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/cssutils')
-rw-r--r--dev-python/cssutils/cssutils-1.0.2-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.2-r1.ebuild b/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
index 3e02fd56a0a7..9963ab692488 100644
--- a/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
+++ b/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
@@ -35,6 +35,10 @@ python_prepare_all() {
-e '/tests_require/d' \
-i setup.py || die
+ # fix casing of call to Windows-1252. Remove when upstream fixes casing.
+ sed -i -e 's/encutils.tryEncodings(test)/encutils.tryEncodings(test).lower()/' \
+ src/cssutils/tests/test_encutils/__init__.py || die "fixing test_encutils failed"
+
distutils-r1_python_prepare_all
}