summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Vielberth <code@peter-vielberth.de>2021-02-22 00:51:39 +0100
committerSam James <sam@gentoo.org>2021-03-09 09:44:32 +0000
commit0b4f9ca19c518501891e2046721dea49724e612a (patch)
tree76bb4b34b684b4270cd11879be45ffd2275d5414 /dev-python/click
parentdev-python/elasticsearch-py: added python 3.9 support (diff)
downloadgentoo-0b4f9ca19c518501891e2046721dea49724e612a.tar.gz
gentoo-0b4f9ca19c518501891e2046721dea49724e612a.tar.bz2
gentoo-0b4f9ca19c518501891e2046721dea49724e612a.zip
dev-python/click: added python 3.9 support
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Peter Vielberth <code@peter-vielberth.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/click-6.7-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/click/click-6.7-r3.ebuild b/dev-python/click/click-6.7-r3.ebuild
new file mode 100644
index 000000000000..6a6ff97cc066
--- /dev/null
+++ b/dev-python/click/click-6.7-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ # From upstream, can be removed in next release.
+ "${FILESDIR}/${PN}-6.7-fix-tests.patch"
+ # From upstream, can be removed in next release.
+ "${FILESDIR}/${PN}-6.7-support-sphinx-1.7.patch"
+)
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}