summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-31 08:53:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-31 09:33:36 +0100
commit1fedbc641179d44901b61a09361532fe131e899b (patch)
tree690249d91586bca48d2801850fffd52f1d517c97 /dev-python/botocore
parentwww-apps/wordpress: bump to 5.5.3 (diff)
downloadgentoo-1fedbc641179d44901b61a09361532fe131e899b.tar.gz
gentoo-1fedbc641179d44901b61a09361532fe131e899b.tar.bz2
gentoo-1fedbc641179d44901b61a09361532fe131e899b.zip
dev-python/botocore: Bump to 1.19.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.9.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index a5ee4db3946d..ab7c9ab2dfe7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,3 +10,4 @@ DIST botocore-1.19.5.tar.gz 6962056 BLAKE2B 261be573224ec07930f4f833193bae78d5bc
DIST botocore-1.19.6.tar.gz 6963086 BLAKE2B d9805f95f6bdb5ef85eb474c270b4c37f6150a281c542e64938a1b9ceaed8faa03464a69ca45988eed85f61fc70aef41548dda8112e0d1cf71cc67fb33a6ab47 SHA512 da8c9c00417fa41f8f991babe15ac09dd8dad871548e53d5fe0560a8cffa478fbad0d2ded03fb3e693dbb83076fc578db5217ec9a419ac2c71bf04a4fefd68f1
DIST botocore-1.19.7.tar.gz 6966051 BLAKE2B 1693452d50da92134da7e76011ebd7e55bed5aa4b240a886021ab8b517b88ff92424acdf7acf341f186bdb7d3ceb2dd9d04265d98469c1d8f2f99569a4f3a891 SHA512 cce829a8704e8b27f20d14ac84b0a93bbceddf542abc1750361e36b03d2a924b1f8922fdd82e0ee5ebecc98ff38feaa45255061b0f927049dfeb27cc6d8c5a9f
DIST botocore-1.19.8.tar.gz 6970481 BLAKE2B 52d3f8ee7dc38feddb3f7799959624b4baf4b75ebcf3ad8257c25ad13b8a8c3cf526ee187681b6d8f5f6ee874071a02c59bd106cb4b4e23ad9cf13b9aa74deef SHA512 845dfec33f63deee44bfffe81801995bfcc2014880c2d520b927421219279107b0fe44dc84425c0a55ddec73d5ad8aeb34f2b84178e1365d137240a2e94370c7
+DIST botocore-1.19.9.tar.gz 6972834 BLAKE2B 3407c056c7995cc1ccb1b5b4c5b3a6254e38672b52e7889a7a022520283416e4dfcabd05c8ca0ed78e4624c7a20c9f43bfde87a76d7a72660b4c95256e4f9ca4 SHA512 8433f22ae7652e524a82da8d2ccda48da9eef44788333898b7526335d57a7757b80754f0d5c6a2c84ec3bde2ec9fc7da5cf872cbda7286f620b4f4878fe9a583
diff --git a/dev-python/botocore/botocore-1.19.9.ebuild b/dev-python/botocore/botocore-1.19.9.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}