summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-18 06:59:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-18 08:02:53 +0200
commite443334ab39bb1098f62a60bc21d21579b9d50ad (patch)
treed1a8a565b20d69584177519ffbe28a45eddc3c99 /dev-python/boto3
parentdev-python/botocore: Bump to 1.31.4 (diff)
downloadgentoo-e443334ab39bb1098f62a60bc21d21579b9d50ad.tar.gz
gentoo-e443334ab39bb1098f62a60bc21d21579b9d50ad.tar.bz2
gentoo-e443334ab39bb1098f62a60bc21d21579b9d50ad.zip
dev-python/boto3: Bump to 1.28.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 76fe27499f06..a1bd9b53ae89 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -10,3 +10,4 @@ DIST boto3-1.28.0.gh.tar.gz 672952 BLAKE2B f648cb49defe36b40138dfe3c125e15bc6480
DIST boto3-1.28.1.gh.tar.gz 673678 BLAKE2B a4f92be4cb7256d37483796a71297bfc01c32c33fe50c54d32398d8227b466b1c6a4ef74c4a26a58a4abcccaeccd64a7faa0d85526d9dd2b33f0befdf48593c8 SHA512 5f7f2c3cc282046bb9660bfac7f176622ea239bc724c8c47c981f92b023598fca564db586d8733a46f3a6037ba85b0cc1f9a8b7b79797e6c3d46f0ce368861e2
DIST boto3-1.28.2.gh.tar.gz 673872 BLAKE2B 9f8a3e299cb6df278756ddafee0956b99ac9db63ff8eb2ad7bf6810e3c4140f6512a7de9963e6a7ddb065affb171d92f1f05226cba7a1e4037464e530d7e536a SHA512 062b5c70079acd5a9b3a0e4f23d44fe9f05f27e621951484e557a852d797c25c590a0ed545c2772326cd0d255cdb56250db2a2544c938f75dccc81a5f6e1d678
DIST boto3-1.28.3.gh.tar.gz 675019 BLAKE2B 93b29307fbfec4e61dc60d28e4f20392ae2a730f048a0b2e8cb99fd515a036fc4ca889ddd564e09b1f3eab4cb9499c5918b4e7430d63148dd2854d126719a468 SHA512 514d0f373f25bb691abf5f1f8b0209a07097191b2ad8fb6339739e7a0bd2b8e6d5a88f1250e928ca89b1f1aa5e27a44bf2cab38a57680c01214d370d11944ded
+DIST boto3-1.28.4.gh.tar.gz 675638 BLAKE2B e5d4cd28b61a79c54c28355003a097f7b40c5c4246c0f755886053214a50fb118c23999e86ae6afe4effdacd0c6ab6847c295d0420ab69986e84a5167278dc41 SHA512 44e89c1455c51032dae1c6745654edea2e44adf9874d726f35ed9edd1de7bc9a571d3fcfa2477b2178b7b028c33e9044745be0d66239eaeee9065cbce112aa54
diff --git a/dev-python/boto3/boto3-1.28.4.ebuild b/dev-python/boto3/boto3-1.28.4.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}