summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-04-03 06:41:34 -0400
committerTim Harder <radhermit@gentoo.org>2018-04-03 16:08:29 -0400
commitf713c620cd644e0a0d9c5d3f993c9879a831c63e (patch)
treefa276e1173de05eaa0a03b05ee77b229e95f4a87 /dev-python/blessings/blessings-1.6.1.ebuild
parentpackage.mask: Mask app-portage/unsandbox for removal (diff)
downloadgentoo-f713c620cd644e0a0d9c5d3f993c9879a831c63e.tar.gz
gentoo-f713c620cd644e0a0d9c5d3f993c9879a831c63e.tar.bz2
gentoo-f713c620cd644e0a0d9c5d3f993c9879a831c63e.zip
dev-python/blessings: version bump to 1.6.1
Diffstat (limited to 'dev-python/blessings/blessings-1.6.1.ebuild')
-rw-r--r--dev-python/blessings/blessings-1.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/blessings/blessings-1.6.1.ebuild b/dev-python/blessings/blessings-1.6.1.ebuild
new file mode 100644
index 000000000000..c6a055d20985
--- /dev/null
+++ b/dev-python/blessings/blessings-1.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A thin, practical wrapper around terminal coloring, styling, and positioning"
+HOMEPAGE="https://github.com/erikrose/blessings https://pypi.python.org/pypi/blessings/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ # The tests need an interactive terminal
+ # https://github.com/erikrose/blessings/issues/117
+ script -eqc "nosetests -w \"${BUILD_DIR}\"" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}