summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-25 13:49:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-25 13:52:54 +0200
commit5f015c1b1dc5d73a686bcc53624aafc3aaa128a9 (patch)
tree6fe886251d9332628fd4a9ead193085f90f3d88f /dev-python/amodem
parentsys-libs/liburing: Stabilize 2.7-r1 arm, #940112 (diff)
downloadgentoo-5f015c1b1dc5d73a686bcc53624aafc3aaa128a9.tar.gz
gentoo-5f015c1b1dc5d73a686bcc53624aafc3aaa128a9.tar.bz2
gentoo-5f015c1b1dc5d73a686bcc53624aafc3aaa128a9.zip
dev-python/amodem: Bump to 1.15.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/amodem')
-rw-r--r--dev-python/amodem/Manifest1
-rw-r--r--dev-python/amodem/amodem-1.15.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/amodem/Manifest b/dev-python/amodem/Manifest
index 5347db28cc92..b76c7b1cddc9 100644
--- a/dev-python/amodem/Manifest
+++ b/dev-python/amodem/Manifest
@@ -1 +1,2 @@
DIST amodem-1.15.4.tar.gz 30661 BLAKE2B eea709db3be5a04c569de85457500d390432d78d6cdfab44780a7be9c885538715157cf5cd94c27a5d4e706d6f23f41dc6f863a72ccf8366de08956c2e50cbff SHA512 19eb8ed24ee93652b911a3a8b10fc89b7d567d8302328d93255d65d82c29c50d06855ba6e4228b2f12d50e7dcaadd4539305a34321a7e96ba87b2da9e25a3391
+DIST amodem-1.15.6.tar.gz 28364 BLAKE2B c0fbcba609845cbf1f8ac488cb51a4e887c31cf19d6bf6c40cfc81dad8dc85e653666ff374c0e6b1dcf751abe7bc1320bb64b3f128f8ca72c787ad393ab0b814 SHA512 91dd64454c4e7d34eb11ee99184ca6c9614883ea72bb680cb6cff27c1167a128d14a751a275a33332d7b72cd6915c595616d3ad49d987ca0cf71cd4d786e8305
diff --git a/dev-python/amodem/amodem-1.15.6.ebuild b/dev-python/amodem/amodem-1.15.6.ebuild
new file mode 100644
index 000000000000..428777db5a1e
--- /dev/null
+++ b/dev-python/amodem/amodem-1.15.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Transmit data between two computers using audio"
+HOMEPAGE="
+ https://github.com/romanz/amodem/
+ https://pypi.org/project/amodem/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest