summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-01-31 21:58:23 +0100
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-31 21:35:58 -0800
commitccdaaa3daae0be0a5cce259f5a194da683afa08c (patch)
tree84e364cd90f6240014fa7e148adfea349027c72e /dev-python/aiosmtpd
parentapp-crypt/nitrocli: Remove 0.2.1 ebuild (diff)
downloadgentoo-ccdaaa3daae0be0a5cce259f5a194da683afa08c.tar.gz
gentoo-ccdaaa3daae0be0a5cce259f5a194da683afa08c.tar.bz2
gentoo-ccdaaa3daae0be0a5cce259f5a194da683afa08c.zip
dev-python/aiosmtpd: use HTTPS, add missing die
Closes: https://github.com/gentoo/gentoo/pull/10955 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.0.ebuild7
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.1.ebuild7
2 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
index 8595ce17c0db..dc3132902308 100644
--- a/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
+++ b/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,18 +7,17 @@ PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
inherit distutils-r1
DESCRIPTION="asyncio based SMTP server"
-HOMEPAGE="http://aiosmtpd.readthedocs.io/"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
src_prepare() {
- rm -r examples
+ rm -r examples || die
distutils-r1_python_prepare_all
}
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.1.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.1.ebuild
index 8595ce17c0db..dc3132902308 100644
--- a/dev-python/aiosmtpd/aiosmtpd-1.1.ebuild
+++ b/dev-python/aiosmtpd/aiosmtpd-1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,18 +7,17 @@ PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
inherit distutils-r1
DESCRIPTION="asyncio based SMTP server"
-HOMEPAGE="http://aiosmtpd.readthedocs.io/"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
src_prepare() {
- rm -r examples
+ rm -r examples || die
distutils-r1_python_prepare_all
}