summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-17 09:33:41 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-17 09:33:41 +0300
commitfc13d2b9bb77e20b39b59c3f159e22b8ee6800d6 (patch)
tree5b35844217233b1dd394bf16ed5235dc5e68ab14 /dev-python/MechanicalSoup
parentdev-python/python-augeas: enable py3.11 (diff)
downloadgentoo-fc13d2b9bb77e20b39b59c3f159e22b8ee6800d6.tar.gz
gentoo-fc13d2b9bb77e20b39b59c3f159e22b8ee6800d6.tar.bz2
gentoo-fc13d2b9bb77e20b39b59c3f159e22b8ee6800d6.zip
dev-python/MechanicalSoup: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/MechanicalSoup')
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-1.1.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-1.1.0-r1.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..e8b5d49a6e53
--- /dev/null
+++ b/dev-python/MechanicalSoup/MechanicalSoup-1.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library for automating interaction with websites"
+HOMEPAGE="https://pypi.org/project/MechanicalSoup/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/beautifulsoup4-4.7[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # Override pytest options to skip coverage and flake8
+ sed -e '/^addopts =/d' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}