summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-03 11:28:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-03 11:50:25 +0100
commitb031aa31015287af7828fbb85a66a566138c8afa (patch)
treea18ec5e42f754515e749cdb027ab8791fd0435ad /dev-python/Babel/Babel-2.9.0.ebuild
parentdev-python/backports-zoneinfo: New backport, dep of Babel (diff)
downloadgentoo-b031aa31015287af7828fbb85a66a566138c8afa.tar.gz
gentoo-b031aa31015287af7828fbb85a66a566138c8afa.tar.bz2
gentoo-b031aa31015287af7828fbb85a66a566138c8afa.zip
dev-python/Babel: Bump to 2.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Babel/Babel-2.9.0.ebuild')
-rw-r--r--dev-python/Babel/Babel-2.9.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.9.0.ebuild b/dev-python/Babel/Babel-2.9.0.ebuild
new file mode 100644
index 000000000000..b10743d637c0
--- /dev/null
+++ b/dev-python/Babel/Babel-2.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="https://babel.pocoo.org/ https://pypi.org/project/Babel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' python3_{6..8} pypy3)"
+DEPEND="${DEPEND}
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/Babel-2.9.0-pypy3.patch
+)
+
+src_test() {
+ local -x TZ=UTC
+ distutils-r1_src_test
+}