summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-11 05:37:37 +0000
committerSam James <sam@gentoo.org>2024-12-11 05:37:37 +0000
commit91fa08615f2a713e3022da6d3d7b23e898febfaf (patch)
treed06fdb8f7aea6ab18c7ce3ea4eb7aefe90ec0819 /dev-php
parentprofiles: update pecl-http mask (diff)
downloadgentoo-91fa08615f2a713e3022da6d3d7b23e898febfaf.tar.gz
gentoo-91fa08615f2a713e3022da6d3d7b23e898febfaf.tar.bz2
gentoo-91fa08615f2a713e3022da6d3d7b23e898febfaf.zip
Revert "dev-php/pecl-http: add 4.2.6"
This reverts commit a7ecf66e9b9b1c43b7692568fefde2a371d8bad9. pecl-raphf needs porting and the dep doesn't seem to have been updated in pecl-http for that either. Bug: https://bugs.gentoo.org/945977 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/pecl-http-4.2.6.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index aa399ed21b6d..c6ecbe7266f4 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,2 +1 @@
DIST pecl_http-4.2.2.tgz 224436 BLAKE2B 26ef3bb38778f0374938ba3f3bddba37c3a2044c7b9ffe2aacbca2566251d26d37882bf66773b8ed62d46855e8f14ad9b577cdb1ef3db9eba9850c0b30e57284 SHA512 1203367d590c7d80ffe7a21e7ac352ba053e3daeb778bf99e08fc13582e665e1429f850e51e36304bdec15e6646b648f2c444b46fa263e5441d008ac41a00f4b
-DIST pecl_http-4.2.6.tgz 225503 BLAKE2B 834c5a38de2ec5525472fbe3a2c92804e3d471cdbd2f0791990bbde3001a4ba63822e9e4600b1a692f117f4fb941c86a78cd533512b7c5cacdad87f055160cfd SHA512 50c921d11e035281bd55152e449ee47d203c839d654b097fcbc5d6d93faf91a6111817b8a7157715de0af9f15c713974a53a2ab318eddd840bc3a7e6b2b50e11
diff --git a/dev-php/pecl-http/pecl-http-4.2.6.ebuild b/dev-php/pecl-http/pecl-http-4.2.6.ebuild
deleted file mode 100644
index 8a95f7e8795f..000000000000
--- a/dev-php/pecl-http/pecl-http-4.2.6.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_INI_NAME="50-http"
-
-USE_PHP="php8-1 php8-2 php8-3"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="8"
-IUSE="ssl curl_ssl_gnutls +curl_ssl_openssl"
-
-COMMON_DEPEND="app-arch/brotli:=
- dev-libs/libevent
- >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-1(-)?]
- net-dns/libidn2
- sys-libs/zlib
- ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=] )
- !ssl? ( net-misc/curl[-ssl] )
-"
-DEPEND="
- php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )
- php_targets_php8-2? ( ${COMMON_DEPEND} dev-lang/php:8.2[session(-),iconv(-)] )
- php_targets_php8-3? ( ${COMMON_DEPEND} dev-lang/php:8.3[session(-),iconv(-)] )"
-RDEPEND="${DEPEND}"
-
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps
- --without-http-libidn-dir --without-http-libicu-dir
- --without-http-libidnkit2-dir --without-http-libidnkit-dir )
-
-src_prepare() {
- php-ext-source-r3_src_prepare
-
- # Respect LDFLAGS, bug 727134
- export EXTRA_LDFLAGS="${LDFLAGS}"
-}
-
-src_test() {
- # Cannot use eclass function due to required modules
- # All tests SKIP otherwise
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
-
- # Link in required modules for testing
- ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
-
- sed -i \
- 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=raphf/' \
- Makefile || die
-
- SKIP_ONLINE_TESTS=yes NO_INTERACTION="yes" emake test
-
- # Clean up testing links
- rm modules/raphf.so || die
- done
-}