summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-15 17:33:57 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-15 17:34:12 -0400
commit6bfb4e9f4353c68f2d1df6d0589fcbdf73480eda (patch)
tree89aeceea1d421d3590c289c49346932ee17858b5 /dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild
parentapp-crypt/openssl-af_alg-engine: renamed to app-crypt/af_alg (diff)
downloadgentoo-6bfb4e9f4353c68f2d1df6d0589fcbdf73480eda.tar.gz
gentoo-6bfb4e9f4353c68f2d1df6d0589fcbdf73480eda.tar.bz2
gentoo-6bfb4e9f4353c68f2d1df6d0589fcbdf73480eda.zip
dev-php/php-redmine-api: version bump 1.5.6 -> 1.5.9.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild')
-rw-r--r--dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild b/dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild
new file mode 100644
index 000000000000..eed676b869b7
--- /dev/null
+++ b/dev-php/php-redmine-api/php-redmine-api-1.5.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A simple, object-oriented, PHP Redmine API client"
+HOMEPAGE="https://github.com/kbsali/${PN}"
+SRC_URI="https://github.com/kbsali/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*[curl,json,simplexml]"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-4 )"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r lib
+
+ dodoc example.php README.markdown
+}
+
+src_test() {
+ phpunit || die "test suite failed"
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/lib/autoload.php'), and then"
+ elog "use the Redmine\\Client class normally. Most of the examples in the"
+ elog "documentation should work without modification."
+}