summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-07 15:58:26 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-07 15:58:26 -0500
commit367db849f8eb9a4c33fc69ab8e8a20848689d04a (patch)
treede085e3b00400dd9dc183a7c0de005543e8eddf4 /dev-php/pecl-yaml/pecl-yaml-2.0.0.ebuild
parentdev-php/pecl-xrange: Drop old (diff)
downloadgentoo-367db849f8eb9a4c33fc69ab8e8a20848689d04a.tar.gz
gentoo-367db849f8eb9a4c33fc69ab8e8a20848689d04a.tar.bz2
gentoo-367db849f8eb9a4c33fc69ab8e8a20848689d04a.zip
dev-php/pecl-yaml: Version bumps to 1.3.0 and 2.0.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/pecl-yaml/pecl-yaml-2.0.0.ebuild')
-rw-r--r--dev-php/pecl-yaml/pecl-yaml-2.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-php/pecl-yaml/pecl-yaml-2.0.0.ebuild b/dev-php/pecl-yaml/pecl-yaml-2.0.0.ebuild
new file mode 100644
index 000000000000..b2dd04016948
--- /dev/null
+++ b/dev-php/pecl-yaml/pecl-yaml-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PV="${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="yaml-${MY_PV}.tgz"
+PHP_EXT_NAME="yaml"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS README )
+
+USE_PHP="php7-0 php5-6"
+
+inherit php-ext-pecl-r3
+
+S="${WORKDIR}/yaml-${MY_PV}"
+PHP_EXT_S="${S}"
+USE_PHP="php7-0"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="YAML 1.1 (YAML Ain't Markup Language) serialization for PHP"
+LICENSE="MIT"
+SLOT="7"
+IUSE=""
+
+DEPEND=">=dev-libs/libyaml-0.1.0"
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-yaml:0[php_targets_php5-6] )"
+PHP_EXT_ECONF_ARGS=""
+
+src_prepare() {
+ if use php_targets_php7-0 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}