summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-redis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-redis')
-rw-r--r--dev-php/pecl-redis/Manifest3
-rw-r--r--dev-php/pecl-redis/metadata.xml14
-rw-r--r--dev-php/pecl-redis/pecl-redis-2.2.3.ebuild32
-rw-r--r--dev-php/pecl-redis/pecl-redis-2.2.5.ebuild32
-rw-r--r--dev-php/pecl-redis/pecl-redis-2.2.7.ebuild35
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
new file mode 100644
index 000000000000..4f14eca0d213
--- /dev/null
+++ b/dev-php/pecl-redis/Manifest
@@ -0,0 +1,3 @@
+DIST redis-2.2.3.tgz 86664 SHA256 87861198403ef7bf09306494f2efc5b55bfdcc6095b7aac059a546a2e662967d SHA512 17ff00c0ee3fa36fa6a2040740c51a9ad36e16be19b9b6df9872138a9015e3f01add59b0b6437c66966fb2850a4c63800b47737e468f4103d7285bdebf377b3b WHIRLPOOL bf0a30d2b9ba399edaddaae7856c6e42e48ed4be88e86a4da88ba5556a7aa36d54a448830810d3ffd3a3e49329f5a8e36a1d0eac9436843fc00b157e0fc592aa
+DIST redis-2.2.5.tgz 96970 SHA256 dceb18c9b563a8da92752ffc2c280beb1b14a86649342af307831a881c053343 SHA512 a0ae16146b97be678d3a25037ada6eb65b4a5cfbc02622c3c056635428851d52634e9d8fef9d393db4787f568d3d4d0c4ebbc740d1b008acc2f168ea5002aeb5 WHIRLPOOL bbb13c9d4b9e9a2d1b60314325cdf0eb921fb2e6d1962919499db89d9a3a11f82ad196c1bff81e404a7133fd21231decd7277b9a537a079d4cdd953fff24d451
+DIST redis-2.2.7.tgz 134340 SHA256 95e5331cd7e709771eb4479c455bcf326a74b2aea3b1a5cba00b4c95e66dc902 SHA512 88be2abeda62b7c1c95b6d399bbb5f97774d956001b4d13a8e5f183e86fe6336d91f479a8125adcaeff1ad5617a920953961360fc3484ebafc3ed915bcd7f86c WHIRLPOOL e7c8ea7c0c4578933211d4571d742ad09eadb5dd93e207d4f0d5858bfacb7a78eb4bd7ed34cafbc17b465b0d423ea0ff788dee907d89c4939ee4a9acbbe8b95d
diff --git a/dev-php/pecl-redis/metadata.xml b/dev-php/pecl-redis/metadata.xml
new file mode 100644
index 000000000000..f18c6324cd03
--- /dev/null
+++ b/dev-php/pecl-redis/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>olemarkus@gentoo.org</email>
+ <name>Ole Markus With</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <use>
+ <flag name="igbinary">Enables igbinary serialisation support</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/dev-php/pecl-redis/pecl-redis-2.2.3.ebuild b/dev-php/pecl-redis/pecl-redis-2.2.3.ebuild
new file mode 100644
index 000000000000..56f8f55e754f
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-2.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="redis"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-5 php5-4"
+
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="amd64"
+
+DESCRIPTION="This extension provides an API for communicating with Redis servers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="igbinary"
+
+DEPEND="igbinary? ( dev-php/igbinary )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ my_conf="--enable-redis
+ $(use_enable igbinary redis-igbinary)"
+
+ php-ext-source-r2_src_configure
+}
diff --git a/dev-php/pecl-redis/pecl-redis-2.2.5.ebuild b/dev-php/pecl-redis/pecl-redis-2.2.5.ebuild
new file mode 100644
index 000000000000..574e25e2bb2b
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-2.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="redis"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="This extension provides an API for communicating with Redis servers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="igbinary"
+
+DEPEND="igbinary? ( dev-php/igbinary )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ my_conf="--enable-redis
+ $(use_enable igbinary redis-igbinary)"
+
+ php-ext-source-r2_src_configure
+}
diff --git a/dev-php/pecl-redis/pecl-redis-2.2.7.ebuild b/dev-php/pecl-redis/pecl-redis-2.2.7.ebuild
new file mode 100644
index 000000000000..604aa735d4ac
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-2.2.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="redis"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="amd64"
+
+DESCRIPTION="This extension provides an API for communicating with Redis servers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="igbinary"
+
+DEPEND="igbinary? ( php_targets_php5-4? ( dev-php/igbinary[php_targets_php5-4] )
+ php_targets_php5-5? ( dev-php/igbinary[php_targets_php5-5] )
+ php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] )
+ )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ my_conf="--enable-redis
+ $(use_enable igbinary redis-igbinary)"
+
+ php-ext-source-r2_src_configure
+}