summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-10-04 13:04:00 -0400
committerBrian Evans <grknight@gentoo.org>2019-10-04 13:04:00 -0400
commit732acb31261ba6b1d2766e4dc6ee6217afe60c51 (patch)
tree827d94d34c383777e0990b5eb7666b773568b575 /dev-php/pecl-redis/pecl-redis-5.0.2.ebuild
parentdev-lang/php: Convert apache dependency to work on all versions (diff)
downloadgentoo-732acb31261ba6b1d2766e4dc6ee6217afe60c51.tar.gz
gentoo-732acb31261ba6b1d2766e4dc6ee6217afe60c51.tar.bz2
gentoo-732acb31261ba6b1d2766e4dc6ee6217afe60c51.zip
dev-php/pecl-redis: Version bump for 5.0.2
Closes: https://bugs.gentoo.org/692148 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-redis/pecl-redis-5.0.2.ebuild')
-rw-r--r--dev-php/pecl-redis/pecl-redis-5.0.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-5.0.2.ebuild b/dev-php/pecl-redis/pecl-redis-5.0.2.ebuild
new file mode 100644
index 000000000000..61a6320308de
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-5.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_NAME="redis"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+PHP_EXT_NEEDED_USE="json?,session?"
+DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="igbinary +json +session"
+
+DEPEND="
+ igbinary? ( dev-php/igbinary[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?,php_targets_php7-4?] )
+"
+RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable json redis-json)
+ $(use_enable session redis-session)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test(){
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}