summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-10-19 15:36:42 -0400
committerBrian Evans <grknight@gentoo.org>2017-10-19 15:36:42 -0400
commite00949d9fe4e70664d843c433e4d87318161e45c (patch)
tree45e6b478d093551336294ab4ca64ed520b73cb4f /dev-php/libvirt-php/libvirt-php-0.5.2.ebuild
parentdev-libs/ossp-uuid: Drop old revisions (diff)
downloadgentoo-e00949d9fe4e70664d843c433e4d87318161e45c.tar.gz
gentoo-e00949d9fe4e70664d843c433e4d87318161e45c.tar.bz2
gentoo-e00949d9fe4e70664d843c433e4d87318161e45c.zip
dev-php/libvirt-php: Drop old
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-php/libvirt-php/libvirt-php-0.5.2.ebuild')
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.5.2.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-php/libvirt-php/libvirt-php-0.5.2.ebuild b/dev-php/libvirt-php/libvirt-php-0.5.2.ebuild
deleted file mode 100644
index bc4fa0c889b2..000000000000
--- a/dev-php/libvirt-php/libvirt-php-0.5.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PHP_EXT_NAME="libvirt-php"
-PHP_EXT_SKIP_PHPIZE="yes"
-USE_PHP="php5-6"
-
-inherit php-ext-source-r2 eutils
-
-DESCRIPTION="PHP 5 bindings for libvirt"
-HOMEPAGE="http://libvirt.org/php/"
-SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-RDEPEND="app-emulation/libvirt
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- doc? ( app-text/xhtml1 )"
-
-RESTRICT="test"
-
-src_unpack() {
- default
-
- # create the default modules directory to be able
- # to use the php-ext-source-r2 eclass to configure/build
- ln -s src "${S}/modules"
-
- for slot in $(php_get_slots); do
- cp -r "${S}" "${WORKDIR}/${slot}"
- done
-}
-
-src_install() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env ${slot}
- insinto "${EXT_DIR}"
- newins "src/.libs/${PHP_EXT_NAME}.so.0.0.0" "${PHP_EXT_NAME}.so"
- done
- php-ext-source-r2_createinifiles
- dodoc AUTHORS ChangeLog NEWS README
- use doc && dohtml docs/* docs/graphics/*
-}