summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-04-29 23:24:12 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-04-29 23:31:02 +0200
commit7e75803b637f9fe2731ba91bf416f7dee88a43da (patch)
tree6d7acf2b680b7ab58e80bc5025b77af91c62abf6 /dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.7.ebuild
parentdev-php/pecl-lzf: bump to v1.6.8 (diff)
downloadgentoo-7e75803b637f9fe2731ba91bf416f7dee88a43da.tar.gz
gentoo-7e75803b637f9fe2731ba91bf416f7dee88a43da.tar.bz2
gentoo-7e75803b637f9fe2731ba91bf416f7dee88a43da.zip
dev-php/PEAR-Mail_Mime: bump to v1.10.7
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.7.ebuild')
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.7.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.7.ebuild
new file mode 100644
index 000000000000..a88d469a1fcd
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit php-pear-r2
+
+DESCRIPTION="Create and manipulate mime messages with PHP"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}