summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-17 21:45:41 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-17 22:01:27 +0100
commit6feee8d55100c335af149fa0959c24f33596f5f0 (patch)
treeab9c063de25dd56affa49236bf6265d17fa8daf8 /dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild
parentdev-php/jsonlint: bump to v1.7.2 (diff)
downloadgentoo-6feee8d55100c335af149fa0959c24f33596f5f0.tar.gz
gentoo-6feee8d55100c335af149fa0959c24f33596f5f0.tar.bz2
gentoo-6feee8d55100c335af149fa0959c24f33596f5f0.zip
dev-php/PEAR-Mail_Mime: bump to v1.10.4
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild')
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild
new file mode 100644
index 000000000000..e23d097da656
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit php-pear-r2
+
+DESCRIPTION="Create and manipulate mime messages with PHP"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}