summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-23 22:53:01 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-23 22:54:47 +1300
commit9a0de919f194c79521db067b4086e8331f57066e (patch)
tree44e197cee2113830fb73c0f727a5a21a66592294 /dev-perl/WWW-Mechanize/WWW-Mechanize-1.840.0.ebuild
parentapp-emulation/wine: Detect and warn about GCC-5.4 compilation issues (diff)
downloadgentoo-9a0de919f194c79521db067b4086e8331f57066e.tar.gz
gentoo-9a0de919f194c79521db067b4086e8331f57066e.tar.bz2
gentoo-9a0de919f194c79521db067b4086e8331f57066e.zip
dev-perl/WWW-Mechanize: Bump to version 1.840.0
Upstream: - Fix submit_form with multiple filters - Workaround HTTP::Cookies bug in reload() - Fix HTTPS tests when no LWP::Proto::https installed - Add strict_forms flag to submit_form() - Live tests are now author tests - Parse url/href for js window open - mech-dump STDOUT is now utf8 - mech-dump now has --version option - Don't die on uri() when there is no request - Test fixes. Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/WWW-Mechanize/WWW-Mechanize-1.840.0.ebuild')
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.840.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.840.0.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.840.0.ebuild
new file mode 100644
index 000000000000..0ff1c57b25d0
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.840.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=1.84
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Getopt-Long
+ dev-perl/HTML-Form
+ >=dev-perl/HTML-Parser-3.340.0
+ dev-perl/HTML-Tree
+ dev-perl/HTTP-Cookies
+ dev-perl/HTTP-Message
+ >=dev-perl/libwww-perl-5.827.0
+ virtual/perl-Tie-RefHash
+ >=dev-perl/URI-1.360.0
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-perl/CGI-4.320.0
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/HTTP-Daemon
+ dev-perl/HTTP-Server-Simple
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ dev-perl/Test-Needs
+ dev-perl/Test-Output
+ dev-perl/Test-RequiresInternet
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warnings
+ )
+"
+
+src_test() {
+ perl_rm_files t/author-*.t
+ perl-module_src_test
+}