summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-06 02:42:38 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-08 01:07:41 +0200
commit0ba47a2296b080148a02af4162a8a002e00b2a98 (patch)
tree0500cfb2e0833b0332c3a1043790394dd631a208 /dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild
parentdev-perl/POE-Component-Client-DNS: Bump to version 0.54.0 (diff)
downloadgentoo-0ba47a2296b080148a02af4162a8a002e00b2a98.tar.gz
gentoo-0ba47a2296b080148a02af4162a8a002e00b2a98.tar.bz2
gentoo-0ba47a2296b080148a02af4162a8a002e00b2a98.zip
dev-perl/POE-Component-IKC: Bump to version 0.240.200
- EAPI6 - DESCRIPTION updated - tests cleaned up - more documentation installed - USE="examples" available Upstream: - Server/on_error added - Error monitor added - create_ikc_* now visibly deprecated - Timing bug avoided with filters - Ports no longer hard-coded Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild')
-rw-r--r--dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild b/dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild
new file mode 100644
index 000000000000..7a173ed54957
--- /dev/null
+++ b/dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=GWYN
+DIST_VERSION=0.2402
+inherit perl-module
+
+DESCRIPTION="Inter-Kernel Communication for POE"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test examples"
+
+RDEPEND="
+ >=dev-perl/Data-Dump-1.0.0
+ >=dev-perl/Devel-Size-0.770.0
+ >=dev-perl/POE-1.311.0
+ >=virtual/perl-Scalar-List-Utils-1.0.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.600.0 )
+"
+
+src_test() {
+ perl_rm_files t/01_pod.t t/02_pod_coverage.t
+ perl-module_src_test
+}
+
+src_install() {
+ perl-module_src_install
+ dodoc FUTUR ikc-architecture.txt
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r eg/*
+ fi
+}