summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Net-LDAPapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Net-LDAPapi')
-rw-r--r--dev-perl/Net-LDAPapi/Manifest1
-rw-r--r--dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.3-r2.ebuild43
-rw-r--r--dev-perl/Net-LDAPapi/files/3.0.3-ldap_result-no_error.patch14
-rw-r--r--dev-perl/Net-LDAPapi/metadata.xml14
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-perl/Net-LDAPapi/Manifest b/dev-perl/Net-LDAPapi/Manifest
new file mode 100644
index 000000000000..70ea0d8eaea1
--- /dev/null
+++ b/dev-perl/Net-LDAPapi/Manifest
@@ -0,0 +1 @@
+DIST Net-LDAPapi-3.0.3.tar.gz 55369 SHA256 8266a0493d6e771635c6788e80ae8e4d480c9a4dd752825e5dc903b9570325fb SHA512 8935233eaf9bf5ba5595ecd8c1659edcb8b032a4b1595ffcc31562b23e9155507183b9f6c4d9a76021257ed074155275ad5d20c23a5d873c7e7a64b7adc41f0a WHIRLPOOL cd7f83950dadbba89097a25cc6c40d370381d40eaada7de69a1afcdfe64f32dd116462e7aa859700f1f58a11c7d6d7d9a977819142833c87a0677ae05b59acb7
diff --git a/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.3-r2.ebuild b/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.3-r2.ebuild
new file mode 100644
index 000000000000..74a6bcacf555
--- /dev/null
+++ b/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.3-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR="MISHIKAL"
+
+inherit eutils multilib perl-module
+
+DESCRIPTION="Perl5 Module Supporting LDAP API"
+HOMEPAGE="http://sourceforge.net/projects/net-ldapapi/
+ http://search.cpan.org/~mishikal/Net-LDAPapi/"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+# LICENSE is given on the corresponding sourceforge project and matches the
+# default cpan/perl license
+
+COMMON="net-nds/openldap[sasl]
+ dev-libs/cyrus-sasl
+ dev-perl/Convert-ASN1"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+# NOTE: tests are available but they hang
+
+PATCHES=("${FILESDIR}/${PV}-ldap_result-no_error.patch")
+
+src_configure() {
+ myconf="-sdk OpenLDAP -lib_path /usr/$(get_libdir) -include_path /usr/include"
+ perl-module_src_configure
+}
+
+src_install() {
+ mydoc="Credits Todo"
+ perl-module_src_install
+ if use examples ; then
+ docompress -x usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-perl/Net-LDAPapi/files/3.0.3-ldap_result-no_error.patch b/dev-perl/Net-LDAPapi/files/3.0.3-ldap_result-no_error.patch
new file mode 100644
index 000000000000..d1003ee9ae7e
--- /dev/null
+++ b/dev-perl/Net-LDAPapi/files/3.0.3-ldap_result-no_error.patch
@@ -0,0 +1,14 @@
+diff --git a/LDAPapi.pm b/LDAPapi.pm
+index 113d922..cba3b61 100644
+--- a/LDAPapi.pm
++++ b/LDAPapi.pm
+@@ -1355,8 +1355,8 @@ sub result
+ $self->{"result"} = $result;
+ $self->{"status"} = $status;
+
+- $self->errorize($status);
+ if( $status == -1 || $status == 0 ) {
++ $self->errorize($status);
+ return undef;
+ }
+
diff --git a/dev-perl/Net-LDAPapi/metadata.xml b/dev-perl/Net-LDAPapi/metadata.xml
new file mode 100644
index 000000000000..af2fb93e808e
--- /dev/null
+++ b/dev-perl/Net-LDAPapi/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="sourceforge">net-ldapapi</remote-id>
+ <remote-id type="cpan">Net-LDAPapi</remote-id>
+ <remote-id type="cpan-module">Net::LDAPapi</remote-id>
+ </upstream>
+</pkgmetadata>