summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-26 05:42:51 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-26 05:43:25 +1300
commita41210bac581431203050583ce6392870d65dc84 (patch)
tree4f85121873b4d0dfd95db83a5f48673499e69e9f /dev-perl/IO-Prompt/IO-Prompt-0.997.4.ebuild
parentvirtual/python-pathlib: Enable pypy3 (diff)
downloadgentoo-a41210bac581431203050583ce6392870d65dc84.tar.gz
gentoo-a41210bac581431203050583ce6392870d65dc84.tar.bz2
gentoo-a41210bac581431203050583ce6392870d65dc84.zip
dev-perl/IO-Prompt: Bump to version 0.997.4
- EAPI6 - Add USE=examples - Cleanup authortests Upstream: - Removed use of POSIX::isprint (deprecated) Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/IO-Prompt/IO-Prompt-0.997.4.ebuild')
-rw-r--r--dev-perl/IO-Prompt/IO-Prompt-0.997.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/IO-Prompt/IO-Prompt-0.997.4.ebuild b/dev-perl/IO-Prompt/IO-Prompt-0.997.4.ebuild
new file mode 100644
index 000000000000..2f18a258450c
--- /dev/null
+++ b/dev-perl/IO-Prompt/IO-Prompt-0.997.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DCONWAY
+DIST_VERSION=0.997004
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Interactively prompt for user input"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-IO
+ dev-perl/TermReadKey
+ dev-perl/Want
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_test() {
+ perl_rm_files "t/pod.t" "t/pod-coverage.t"
+ perl-module_src_test
+}