summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-26 15:07:16 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-26 15:07:16 +1300
commit7b98533741a5f3773bf0c9209e2f8bd937bcd9ef (patch)
tree3e173d4e050fd94ca276be14c46692222e284d15 /dev-perl/IO-Interactive/IO-Interactive-1.22.0.ebuild
parentdev-perl/IO-AIO: Bump to version 4.340.0 (diff)
downloadgentoo-7b98533741a5f3773bf0c9209e2f8bd937bcd9ef.tar.gz
gentoo-7b98533741a5f3773bf0c9209e2f8bd937bcd9ef.tar.bz2
gentoo-7b98533741a5f3773bf0c9209e2f8bd937bcd9ef.zip
dev-perl/IO-Interactive: Bump to version 1.22.0
Upstream: - Lazy-load Carp Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/IO-Interactive/IO-Interactive-1.22.0.ebuild')
-rw-r--r--dev-perl/IO-Interactive/IO-Interactive-1.22.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/IO-Interactive/IO-Interactive-1.22.0.ebuild b/dev-perl/IO-Interactive/IO-Interactive-1.22.0.ebuild
new file mode 100644
index 000000000000..1e58b67a7442
--- /dev/null
+++ b/dev-perl/IO-Interactive/IO-Interactive-1.22.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=1.022
+inherit perl-module
+
+DESCRIPTION="Utilities for interactive I/O"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-version-0.780.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ virtual/perl-File-Spec
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+src_test() {
+ perl_rm_files "t/pod.t" "t/pod-coverage.t"
+ perl-module_src_test
+}