summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-31 19:09:16 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-31 19:09:58 +1200
commit6bc5543f4cf2b0d0fc18a535b326bb62ae9d42f8 (patch)
treee451eac0fb544cdb1cef98f5cbdc3d22439614a8 /dev-perl/File-RsyncP
parentsys-apps/portage: Bump to version 3.0.5 (diff)
downloadgentoo-6bc5543f4cf2b0d0fc18a535b326bb62ae9d42f8.tar.gz
gentoo-6bc5543f4cf2b0d0fc18a535b326bb62ae9d42f8.tar.bz2
gentoo-6bc5543f4cf2b0d0fc18a535b326bb62ae9d42f8.zip
dev-perl/File-RsyncP: -r bump for EAPI7 + Fixes
- EAPI7 - Fix LICENSE - Ensure CFLAGS passed to make/compile - Minor dep improvement - Remove empty/unused variable assignments Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/File-RsyncP')
-rw-r--r--dev-perl/File-RsyncP/File-RsyncP-0.740.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/File-RsyncP/File-RsyncP-0.740.0-r1.ebuild b/dev-perl/File-RsyncP/File-RsyncP-0.740.0-r1.ebuild
new file mode 100644
index 000000000000..8d726fc79812
--- /dev/null
+++ b/dev-perl/File-RsyncP/File-RsyncP-0.740.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CBARRATT
+DIST_VERSION=0.74
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="An rsync perl module"
+HOMEPAGE="http://perlrsync.sourceforge.net/ https://metacpan.org/release/File-RsyncP"
+# Bundled files make for some weirdness
+LICENSE="GPL-3+ GPL-2+ RSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Getopt-Long-2.240.0
+ net-misc/rsync
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.700.0-make.patch" )
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}