summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Exception-Base
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Exception-Base')
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.250-r1.ebuild30
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild34
-rw-r--r--dev-perl/Exception-Base/Manifest1
-rw-r--r--dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch52
-rw-r--r--dev-perl/Exception-Base/metadata.xml9
5 files changed, 126 insertions, 0 deletions
diff --git a/dev-perl/Exception-Base/Exception-Base-0.250-r1.ebuild b/dev-perl/Exception-Base/Exception-Base-0.250-r1.ebuild
new file mode 100644
index 000000000000..5f646d9995fa
--- /dev/null
+++ b/dev-perl/Exception-Base/Exception-Base-0.250-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DEXTER
+MODULE_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Error handling with exception class"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Package warrants IUSE examples
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( >=dev-perl/Test-Unit-Lite-0.12 )"
+
+SRC_TEST="do"
+
+src_install(){
+ perl-module_src_install
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+}
diff --git a/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild b/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild
new file mode 100644
index 000000000000..eaadf2ff7ca4
--- /dev/null
+++ b/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DEXTER
+MODULE_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Error handling with exception class"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( >=dev-perl/Test-Unit-Lite-0.120.0 )
+"
+
+SRC_TEST="do parallel"
+
+PATCHES=(
+ "${FILESDIR}/${P}-sprintf.patch"
+)
+
+src_install(){
+ perl-module_src_install
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+}
diff --git a/dev-perl/Exception-Base/Manifest b/dev-perl/Exception-Base/Manifest
new file mode 100644
index 000000000000..6af08134984e
--- /dev/null
+++ b/dev-perl/Exception-Base/Manifest
@@ -0,0 +1 @@
+DIST Exception-Base-0.25.tar.gz 59534 SHA256 1c4ec484ec6154b4b3c477d1ce69f666289fe9b4c2f2318cf742ad2e0cd251e8 SHA512 4bc416a8a4096b2149a205dc3129aabaa49bfa9f29746b31a09cbade01e15d53ed82649b75d69c508568a7fb12726e319360aba128102fdc1e0a7ba583473e65 WHIRLPOOL 75ccac808f019da61d3ed843ed680274cabf5a509f332bc0b13e64b075961ce383243cabe821cbf11116f08d96609fd9d380604e0dd094524febaf24908519af
diff --git a/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch b/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch
new file mode 100644
index 000000000000..656c3eba4ee3
--- /dev/null
+++ b/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch
@@ -0,0 +1,52 @@
+From 1cb0ea6afd4bb76e5a1d759efe27ea0f18306a82 Mon Sep 17 00:00:00 2001
+From: Lee Johnson <lee@givengain.ch>
+Date: Thu, 1 Jan 2015 22:33:54 +0000
+Subject: [PATCH] resolve #1 - fix warnings new since perl 5.21.2
+
+Redundant argument in %s - this is because the various calls to the
+sprintf function offset the arrays by 1 (since the first element of
+the array is the sprintf string) but use @_ (the number of elements
+in the array) in the range: 1 .. @_
+
+since it's offset by 1 we are going beyond the end of the array and
+so sprintf consequently warns that we sent more arguments than it
+expected. fix this by using @_ -1 in the range (number of elements
+in the array minus 1)
+---
+ lib/Exception/Base.pm | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/lib/Exception/Base.pm b/lib/Exception/Base.pm
+index 8dce19f..096e2a5 100644
+--- a/lib/Exception/Base.pm
++++ b/lib/Exception/Base.pm
+@@ -1362,7 +1362,7 @@ sub matches { ## no critic qw(ProhibitExcessComplexity)
+ local $_ = ref $self->{$key} eq 'ARRAY'
+ ? sprintf(
+ @{$self->{$key}}[0],
+- @{$self->{$key}}[1..@{$self->{$key}}]
++ @{$self->{$key}}[1..@{$self->{$key}}-1]
+ )
+ : $self->{$key};
+ if (ref $arrval eq 'CODE') {
+@@ -1393,7 +1393,7 @@ sub matches { ## no critic qw(ProhibitExcessComplexity)
+ local $_ = ref $self->{$key} eq 'ARRAY'
+ ? sprintf(
+ @{$self->{$key}}[0],
+- @{$self->{$key}}[1..@{$self->{$key}}]
++ @{$self->{$key}}[1..@{$self->{$key}}-1]
+ )
+ : $self->{$key};
+
+@@ -1613,7 +1613,7 @@ sub _string_attributes {
+ my ($self) = @_;
+
+ return map { ref $_ eq 'ARRAY'
+- ? sprintf(@$_[0], @$_[1..@$_])
++ ? sprintf(@$_[0], @$_[1..@$_-1])
+ : $_ }
+ grep { defined $_ and (ref $_ or $_ ne '') }
+ map { $self->{$_} }
+--
+2.4.5
+
diff --git a/dev-perl/Exception-Base/metadata.xml b/dev-perl/Exception-Base/metadata.xml
new file mode 100644
index 000000000000..c15160fe20e2
--- /dev/null
+++ b/dev-perl/Exception-Base/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Exception-Base</remote-id>
+ <remote-id type="cpan-module">Exception::Base</remote-id>
+ </upstream>
+</pkgmetadata>