summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/ocamldap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/ocamldap')
-rw-r--r--dev-ml/ocamldap/Manifest1
-rw-r--r--dev-ml/ocamldap/files/ocaml-4.02.patch13
-rw-r--r--dev-ml/ocamldap/metadata.xml21
-rw-r--r--dev-ml/ocamldap/ocamldap-2.2.ebuild29
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ml/ocamldap/Manifest b/dev-ml/ocamldap/Manifest
new file mode 100644
index 000000000000..c3e8bc6c960f
--- /dev/null
+++ b/dev-ml/ocamldap/Manifest
@@ -0,0 +1 @@
+DIST ocamldap-2.2.tar.gz 174204 SHA256 19da4383c76b22eea22f9ba50b55829fa6a4ed430d58b6291545dfbe57449804 SHA512 e24e78497b7c9ed89b0ae73c5773cc9ec28c7c7d317b4b8b39f6b20536ff8f44e15c2657d6aba4bb4689afb5bb155fc7391bea6edab50d0855b22bc457982a2d WHIRLPOOL 5e93f761d44aa4e7249a8c04f31d42fcf0b1872610b08a21b3289796209cdea537f5f8d87421e036fe5ffa9de160af2b833020aac347cde91dd91228a5ed5843
diff --git a/dev-ml/ocamldap/files/ocaml-4.02.patch b/dev-ml/ocamldap/files/ocaml-4.02.patch
new file mode 100644
index 000000000000..959ddd0a5a4f
--- /dev/null
+++ b/dev-ml/ocamldap/files/ocaml-4.02.patch
@@ -0,0 +1,13 @@
+diff --git a/src/ldap_ooclient.ml b/src/ldap_ooclient.ml
+index 79fd51d..7ffa39e 100644
+--- a/src/ldap_ooclient.ml
++++ b/src/ldap_ooclient.ml
+@@ -23,7 +23,7 @@
+ open Ldap_types
+ open Ldap_funclient
+ open Ldap_schemaparser
+-open String
++let lowercase = String.lowercase
+
+ (* types used throughout the library *)
+ (* add types *)
diff --git a/dev-ml/ocamldap/metadata.xml b/dev-ml/ocamldap/metadata.xml
new file mode 100644
index 000000000000..b3e9b2788cec
--- /dev/null
+++ b/dev-ml/ocamldap/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+ <longdescription lang="en">
+Ocamldap is an implementation of the Light Weight Directory Access Protocol,
+and a set of useful tools built around it. It includes high level libraries
+for creating ldap clients and ldap servers. It also includes many of the
+auxiliary tools needed for building intelligent solutions, and interoperating
+with other directories. These include, an rfc2252 schema parser, and an schema
+checker, an ldif parser and printer, a search filter parser (but no printer
+yet), and a rudimentary ldap url parser. While including things already done
+elsewhere is fun, ocamldap adds something as well. So it implements a concept
+which tries to provide a basic unit of abstraction for managing directory data,
+called a service. A service is a bit like a stored search filter that you give
+a name. So you can ask ocamldap if an object satisfies its conditions, but
+unlike a search filter you can also ask ocamldap to MAKE an object satisfy its
+conditions. This can be really useful in distributed managment applications.
+Needless to say, more on this in the Documentation section.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/ocamldap/ocamldap-2.2.ebuild b/dev-ml/ocamldap/ocamldap-2.2.ebuild
new file mode 100644
index 000000000000..65f3f4ca0ba1
--- /dev/null
+++ b/dev-ml/ocamldap/ocamldap-2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="an implementation of the Light Weight Directory Access Protocol"
+HOMEPAGE="http://git-jpdeplaix.dyndns.org/libs/ocamldap.git/"
+SRC_URI="http://bitbucket.org/deplai_j/${PN}/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="dev-ml/pcre-ocaml:=
+ dev-ml/ocaml-ssl:=
+ dev-ml/ocamlnet:="
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS.txt Changelog INSTALL.txt README.txt )
+
+PATCHES=( "${FILESDIR}/ocaml-4.02.patch" )
+
+src_install() {
+ oasis_src_install
+ use doc && dohtml -r doc/ocamldap/html
+}