summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-14 13:10:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-14 13:18:03 +0100
commit4dca7b9007e77485a758a1b4eb5280a4228741d5 (patch)
treed7626faaf8a67dd343c0d1e47bd79fc0dcda8942 /dev-ml/ocaml-hashcons/ocaml-hashcons-1.0.ebuild
parentdev-ml/ocaml-uri: bump to 1.9.2 (diff)
downloadgentoo-4dca7b9007e77485a758a1b4eb5280a4228741d5.tar.gz
gentoo-4dca7b9007e77485a758a1b4eb5280a4228741d5.tar.bz2
gentoo-4dca7b9007e77485a758a1b4eb5280a4228741d5.zip
dev-ml/ocaml-hashcons: initial import; ebuild by me
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-hashcons/ocaml-hashcons-1.0.ebuild')
-rw-r--r--dev-ml/ocaml-hashcons/ocaml-hashcons-1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocaml-hashcons/ocaml-hashcons-1.0.ebuild b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.0.ebuild
new file mode 100644
index 000000000000..fbc814e0d950
--- /dev/null
+++ b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools findlib
+
+DESCRIPTION="OCaml hash-consing library"
+HOMEPAGE="https://github.com/backtracking/ocaml-hashcons"
+SRC_URI="https://github.com/backtracking/ocaml-hashcons/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ sed -i -e 's/$(OCAMLFIND) remove/#/' Makefile.in || die
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake opt byte
+ else
+ emake byte
+ fi
+}
+
+src_install() {
+ dodir "$(ocamlfind printconf destdir)/hashcons"
+ emake DESTDIR="-destdir ${D}/$(ocamlfind printconf destdir)/" $(usex ocamlopt install-opt install-byte)
+ dodoc README.md CHANGES
+}