summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-21 02:46:23 +0100
committerSam James <sam@gentoo.org>2022-06-21 02:46:23 +0100
commit2536b2cd6a1646b9ea8a0770ad6c72e20d95075f (patch)
treeedf28d8c2270fad45dfec44e1c99e4b6ce7102d7 /dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3-r1.ebuild
parentdev-ml/gen: fix OCaml dep (diff)
downloadgentoo-2536b2cd6a1646b9ea8a0770ad6c72e20d95075f.tar.gz
gentoo-2536b2cd6a1646b9ea8a0770ad6c72e20d95075f.tar.bz2
gentoo-2536b2cd6a1646b9ea8a0770ad6c72e20d95075f.zip
dev-ml/ocaml-fileutils: fix OCaml dep
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3-r1.ebuild')
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3-r1.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..bb4eea0dfd37
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="fileutils"
+
+inherit dune
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
+SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-v${PV}.tbz -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-ml/ounit2-2.0.0
+ >=dev-ml/stdlib-shims-0.2.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md" "CHANGES.md" "LICENSE.txt" )
+
+S="${WORKDIR}/${DUNE_PKG_NAME}-v${PV}"
+
+src_prepare() {
+ default
+
+ # Port to dev-ml/ounit2
+ sed -i -e 's/oUnit/ounit2/' test/dune || die
+}