summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-04-16 10:30:24 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-04-16 10:40:41 +0200
commit466142bb7316b9c3b7c9e817e9f9abd7b67e4277 (patch)
treeb6ab5b9b2b97967f5a28a40141b91e2a94c06ed9 /dev-ml/dune-private-libs/dune-private-libs-3.7.1.ebuild
parentdev-ml/dune-build-info: add 3.7.1 (diff)
downloadgentoo-466142bb7316b9c3b7c9e817e9f9abd7b67e4277.tar.gz
gentoo-466142bb7316b9c3b7c9e817e9f9abd7b67e4277.tar.bz2
gentoo-466142bb7316b9c3b7c9e817e9f9abd7b67e4277.zip
dev-ml/dune-private-libs: add 3.7.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/dune-private-libs/dune-private-libs-3.7.1.ebuild')
-rw-r--r--dev-ml/dune-private-libs/dune-private-libs-3.7.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/dune-private-libs/dune-private-libs-3.7.1.ebuild b/dev-ml/dune-private-libs/dune-private-libs-3.7.1.ebuild
new file mode 100644
index 000000000000..797e233bbac6
--- /dev/null
+++ b/dev-ml/dune-private-libs/dune-private-libs-3.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Private libraries of Dune"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.5"
+DEPEND="
+ >=dev-ml/csexp-1.5:=[ocamlopt?]
+ dev-ml/pp:=[ocamlopt?]
+ ~dev-ml/dyn-${PV}:=[ocamlopt?]
+ ~dev-ml/stdune-${PV}:=[ocamlopt?]
+ >=dev-lang/ocaml-4.08
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}