summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 18:29:03 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 18:44:47 +0100
commit598e6cd9136de0d4fe2d1f9e249571623a63e844 (patch)
tree75c6cd795e0e918dd72f4affcccc9f70c9816a7d /dev-lua/penlight
parentdev-lua/penlight: fix lua deps (diff)
downloadgentoo-598e6cd9136de0d4fe2d1f9e249571623a63e844.tar.gz
gentoo-598e6cd9136de0d4fe2d1f9e249571623a63e844.tar.bz2
gentoo-598e6cd9136de0d4fe2d1f9e249571623a63e844.zip
dev-lua/penlight: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/penlight')
-rw-r--r--dev-lua/penlight/penlight-1.9.2-r100.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-lua/penlight/penlight-1.9.2-r100.ebuild b/dev-lua/penlight/penlight-1.9.2-r100.ebuild
deleted file mode 100644
index fc399a4a51d6..000000000000
--- a/dev-lua/penlight/penlight-1.9.2-r100.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} luajit )
-MY_PN="Penlight"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
-HOMEPAGE="https://github.com/Tieske/Penlight",
-SRC_URI="https://github.com/Tieske/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-DEPEND="${LUA_DEPS}"
-
-RDEPEND="
- >=dev-lua/luafilesystem-1.8.0-r100
- ${DEPEND}
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? ( ${DEPEND} )
-"
-
-HTML_DOCS=( "docs/." )
-
-lua_src_test() {
- ${ELUA} run.lua || die
-}
-
-src_test() {
- # This is a demo app, not a real test
- rm tests/test-app.lua
-
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto $(lua_get_lmod_dir)
- doins -r lua/pl
-
- einstalldocs
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-}