summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/tinyxml2/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/tinyxml2/files')
-rw-r--r--dev-libs/tinyxml2/files/tinyxml2-1.0.1_p20120531-test-return-status.patch9
-rw-r--r--dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch20
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/files/tinyxml2-1.0.1_p20120531-test-return-status.patch b/dev-libs/tinyxml2/files/tinyxml2-1.0.1_p20120531-test-return-status.patch
new file mode 100644
index 000000000000..49d7d8332e3b
--- /dev/null
+++ b/dev-libs/tinyxml2/files/tinyxml2-1.0.1_p20120531-test-return-status.patch
@@ -0,0 +1,9 @@
+--- tinyxml2-1.0.1_p20120531/xmltest.cpp
++++ tinyxml2-1.0.1_p20120531/xmltest.cpp
+@@ -895,5 +895,5 @@
+ #endif
+
+ printf ("\nPass %d, Fail %d\n", gPass, gFail);
+- return 0;
++ return gFail;
+ }
diff --git a/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch b/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch
new file mode 100644
index 000000000000..a6842eecb6e5
--- /dev/null
+++ b/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch
@@ -0,0 +1,20 @@
+--- tinyxml2-1.0.9_p20121123/CMakeLists.txt
++++ tinyxml2-1.0.9_p20121123/CMakeLists.txt
+@@ -55,10 +55,13 @@
+ VERSION "${GENERIC_LIB_VERSION}"
+ SOVERSION "${GENERIC_LIB_SOVERSION}")
+
+-add_executable(test xmltest.cpp)
+-add_dependencies(test tinyxml2)
+-add_dependencies(test ${TARGET_DATA_COPY})
+-target_link_libraries(test tinyxml2)
++set(BUILD_TEST OFF CACHE BOOL "Set to ON to build tests")
++if(BUILD_TEST)
++ add_executable(test xmltest.cpp)
++ add_dependencies(test tinyxml2)
++ add_dependencies(test ${TARGET_DATA_COPY})
++ target_link_libraries(test tinyxml2)
++endif(BUILD_TEST)
+
+
+ if(BUILD_STATIC_LIBS)