summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-15 08:10:16 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-15 08:10:56 +0100
commit48a24729cbf8c2ccf12d084d140a13ffd74c5b33 (patch)
treeabe85a1c83c42a6e8d958b0655fb72bd2d479a3c /dev-libs/sleef/sleef-3.7-r1.ebuild
parentnet-irc/weechat: add 4.4.3 (diff)
downloadgentoo-48a24729cbf8c2ccf12d084d140a13ffd74c5b33.tar.gz
gentoo-48a24729cbf8c2ccf12d084d140a13ffd74c5b33.tar.bz2
gentoo-48a24729cbf8c2ccf12d084d140a13ffd74c5b33.zip
dev-libs/sleef: drop usage of cpu_flags
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-libs/sleef/sleef-3.7-r1.ebuild')
-rw-r--r--dev-libs/sleef/sleef-3.7-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/sleef/sleef-3.7-r1.ebuild b/dev-libs/sleef/sleef-3.7-r1.ebuild
new file mode 100644
index 000000000000..396bce5933a4
--- /dev/null
+++ b/dev-libs/sleef/sleef-3.7-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Implements vectorized versions of C standard math functions"
+HOMEPAGE="https://sleef.org/"
+SRC_URI="https://github.com/shibatch/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( >=dev-libs/mpfr-4.2 )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.6.1-musl.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DSLEEF_DISABLE_FFTW=ON
+ -DSLEEF_BUILD_QUAD=ON
+ -DSLEEF_BUILD_TESTS=$(usex test ON OFF)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+
+ local myctestargs=(
+ -E "iut(y)?purec(fma)?_scalar"
+ )
+ cmake_src_test
+}