summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-08-06 11:11:06 +0200
committerDavid Seifert <soap@gentoo.org>2023-08-06 11:11:06 +0200
commit4838e743967327ee9e9e63dd30d951d921ed0cee (patch)
tree6d9b325a4f73cc2a0a6ee3ec1992df24a28bae34 /dev-libs/opensc
parentapp-crypt/scute: drop 1.7.0 (diff)
downloadgentoo-4838e743967327ee9e9e63dd30d951d921ed0cee.tar.gz
gentoo-4838e743967327ee9e9e63dd30d951d921ed0cee.tar.bz2
gentoo-4838e743967327ee9e9e63dd30d951d921ed0cee.zip
dev-libs/opensc: drop 0.23.0
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/opensc')
-rw-r--r--dev-libs/opensc/opensc-0.23.0.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/dev-libs/opensc/opensc-0.23.0.ebuild b/dev-libs/opensc/opensc-0.23.0.ebuild
deleted file mode 100644
index 5e6d2db59ebf..000000000000
--- a/dev-libs/opensc/opensc-0.23.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 libtool
-
-DESCRIPTION="Libraries and applications to access smartcards"
-HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
-
-if [[ ${PV} == *9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://github.com/OpenSC/OpenSC.git"
-else
- SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="amd64 ppc64 x86"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="ctapi doc openct notify pace +pcsc-lite readline secure-messaging ssl test zlib"
-RESTRICT="!test? ( test )"
-
-RDEPEND="zlib? ( sys-libs/zlib )
- readline? ( sys-libs/readline:0= )
- ssl? ( dev-libs/openssl:0= )
- openct? ( >=dev-libs/openct-0.5.0 )
- pace? ( dev-libs/openpace:= )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
- notify? ( dev-libs/glib:2 )"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- test? ( dev-util/cmocka )"
-BDEPEND="virtual/pkgconfig"
-
-REQUIRED_USE="
- pcsc-lite? ( !openct !ctapi )
- openct? ( !pcsc-lite !ctapi )
- ctapi? ( !pcsc-lite !openct )
- || ( pcsc-lite openct ctapi )"
-
-src_prepare() {
- default
-
- if [[ ${PV} == *9999 ]]; then
- eautoreconf
- else
- elibtoolize
- fi
-}
-
-src_configure() {
- # don't want to run upstream's clang-tidy checks
- export ac_cv_path_CLANGTIDY=""
-
- econf \
- --with-completiondir="$(get_bashcompdir)" \
- --disable-strict \
- --enable-man \
- $(use_enable ctapi) \
- $(use_enable doc) \
- $(use_enable notify) \
- $(use_enable openct) \
- $(use_enable pace openpace) \
- $(use_enable pcsc-lite pcsc) \
- $(use_enable readline) \
- $(use_enable secure-messaging sm) \
- $(use_enable ssl openssl) \
- $(use_enable test cmocka) \
- $(use_enable zlib)
-}
-
-src_install() {
- default
-
- insinto /etc/pkcs11/modules/
- doins "${FILESDIR}"/opensc.module
-
- find "${ED}" -name '*.la' -delete || die
-}