summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-03-14 23:58:18 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-03-15 00:55:07 +1100
commitf33b8f6ef9f6d3b00c6392090cff0b78934343ea (patch)
tree81b9db7b36d4e04c7d26200b65b46e5b31c5d7b1 /dev-libs/mimetic/mimetic-0.9.8.ebuild
parentwww-apps/kibana-bin: bump to version 4.1.6/4.4.2 (diff)
downloadgentoo-f33b8f6ef9f6d3b00c6392090cff0b78934343ea.tar.gz
gentoo-f33b8f6ef9f6d3b00c6392090cff0b78934343ea.tar.bz2
gentoo-f33b8f6ef9f6d3b00c6392090cff0b78934343ea.zip
dev-libs/mimetic: initial import
Gentoo-bug: 77168 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/mimetic/mimetic-0.9.8.ebuild')
-rw-r--r--dev-libs/mimetic/mimetic-0.9.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/mimetic/mimetic-0.9.8.ebuild b/dev-libs/mimetic/mimetic-0.9.8.ebuild
new file mode 100644
index 000000000000..f3a66a6be224
--- /dev/null
+++ b/dev-libs/mimetic/mimetic-0.9.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="C++ MIME library designed to be easy to use and integrate, fast and efficient."
+HOMEPAGE="http://www.codesink.org/mimetic_mime_library.html"
+SRC_URI="http://www.codesink.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ sed -i -e "s|../doxygen.css|doxygen.css|" doc/header.html || die
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc docs
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/html/
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/{README,TODO,test.msg,*.cxx,*.h}
+ fi
+
+ rm "${D}"/usr/$(get_libdir)/libmimetic.la || die
+}