summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-16 02:05:11 +0100
committerSam James <sam@gentoo.org>2021-09-16 02:17:33 +0100
commitd0d32526c2f5a421da0d79cd55d287bab06e260a (patch)
tree1502a57e889ae9d39527a2329ba668fd1b3d4cc5 /dev-libs/libserialport/libserialport-0.1.1-r1.ebuild
parentsys-apps/busybox: add 1.34.0 (diff)
downloadgentoo-d0d32526c2f5a421da0d79cd55d287bab06e260a.tar.gz
gentoo-d0d32526c2f5a421da0d79cd55d287bab06e260a.tar.bz2
gentoo-d0d32526c2f5a421da0d79cd55d287bab06e260a.zip
dev-libs/libserialport: add patch for runtime breakage w/ new kernels
Closes: https://bugs.gentoo.org/813273 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libserialport/libserialport-0.1.1-r1.ebuild')
-rw-r--r--dev-libs/libserialport/libserialport-0.1.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libserialport/libserialport-0.1.1-r1.ebuild b/dev-libs/libserialport/libserialport-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..a06498d3dbfc
--- /dev/null
+++ b/dev-libs/libserialport/libserialport-0.1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://sigrok.org/download/source/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Cross platform serial port access library"
+HOMEPAGE="https://sigrok.org/wiki/Libserialport"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="static-libs"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-kernel-termiox.patch
+)
+
+src_prepare() {
+ default
+
+ #[[ ${PV} == "9999" ]] && eautoreconf
+ # Needed for the termiox patch, should be able to drop on next release
+ # (change back this + inherit to just for 9999)
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}